
Adobe CS5 Production Premium Panasonic P2 Workflow Guide

Adobe Creative Suite 5 Production 
Premium combines the full new 
versions of:
•	�Adobe After Effects CS5

•	�Adobe Premiere Pro CS5

•	�Adobe Photoshop CS5 Extended

•	�Adobe Illustrator CS5

•	�Adobe Flash CS5 Professional

•	�Adobe Flash Catalyst CS5

•	�Adobe Soundbooth CS5

•	�Adobe Encore CS5

•	�Adobe OnLocation CS5

•	�Adobe Device Central, Adobe 
Bridge CS5, and special suite 
features Adobe Dynamic Link 	
and Capture in After Effects

Adobe CS5 Production Premium provides tight, comprehensive support for Panasonic P2 
cameras.  Edit your P2 footage quickly and efficiently with native support, breakthrough 
performance in the 64-bit, GPU-accelerated Mercury Playback Engine, and tight integration 
between Adobe applications.

Adobe CS5 Production Premium is tightly-integrated suite of applications intended to cover every aspect 
of video and content creation, from acquisition in the field, to editing and effects, to audio, through to 
export and delivery.

Adobe Premiere Pro, After Effects, and Encore are principally involved in the P2 workflow.  Most work 
with P2 content will be done in Adobe Premiere Pro, and it will be through Adobe Premiere Pro that 
most of the other CS5 applications will usually be accessed in the P2 workflow. Many of the techniques 
described in this paper are applicable to CS4 programs, but with CS5, the level of performance in the P2 
environment has been greatly enhanced.   Some of these techniques are applicable to CS3 as well.  As of 
CS5, a 64-bit operating system is required for Adobe Premiere Pro and After Effects.

Adobe Premiere Pro provides complete, native timeline support for all current P2 recording formats.  
Adobe Premiere Pro supports DV, DVCPRO, DVCPRO 50, DVCPRO HD, and AVC-Intra at all frame sizes 
and frame rates, both 60 Hz- and 50 Hz-based.  

Working with tapeless P2 media in Adobe Premiere Pro gives you several advantages.  There is no 
transcoding; all formats are supported in their original MXF wrappers as recorded by the P2 camera.  You 
can begin editing the exact files recorded by the cameras immediately after shooting, straight from the 
P2 card, or even straight from the camera --  there is no waiting.  You can share media between users and 
other NLE systems in its native format, and you maintain the full quality of the footage throughout the 
entire production process.

Adobe Premiere Pro also will also display the full metadata recorded with P2 assets.  Some of the 
metadata can be searched and sorted on in the Project panel and also in the new Media Browser panel.

Adobe Premiere Pro provides a full array of export options from the timeline.  Most common formats can 
be accessed through Adobe Media Encoder.  Adobe Premiere Pro will also export, directly or through 
Adobe Media Encoder, a timeline sequence in native P2/MXF format, suitable for swapping between 
editing systems, or even writing directly to a P2 card and accessing in-camera.

After Effects also supports P2 material in its native MXF format.  After Effects supports all frame sizes and 
rates as well, including AVC-Intra.  After Effects can import P2 material directly; it can import Adobe 
Premiere Pro P2 project files and sequences, or it can create composites with P2 material inside an 
Adobe Premiere Pro sequence using Adobe Dynamic Link.

Adobe® Creative Suite 5 Production Premium
End-to-end workflows for Panasonic P2 and P2HD cameras

36  pt.
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Top benefits
•	�Work with native P2/MXF files in all 
P2/P2HD formats and frame rates 
with no transcoding (Page  1)

•	View footage by user-defined 
UserClipName instead of generic 
identifier (Page 12)

• Sort clips on Shot Mark (Page 12)

• View all P2 metadata stored with 
clips (Page 13)

•	Edit AVC-Intra footage at its full 
10-bit depth (Page 18)

•	�Take advantage of the new Mercury 
Playback Engine for enhanced 
timeline performance and 
GPU-accelerated effects(Page 19)

•	�Export to P2 format and create 
virtual P2 cards (Page 19)

•	�Enjoy seamless integration between 
Adobe Premiere Pro and After 
Effects (Page 22)

•	Export to a variety of High-
Definition options (Page 23)

Adobe Encore CS5 can be used to create standard-definition DVDs, Blu-ray DVDs containing High 
Definition material.  It can also be used to create web versions of DVDs -- High Definition Flash 
video for web or DVD content.

All CS5 Production Premium applications are nearly identical between the Windows and Mac 
versions (some very minor differences will be noted later).  Most application project files (Encore 
excepted) work in either platform, so crossing between platforms is as simple as accessing the 
media files and the project files with either system, either over a network, or with external hard 
drives.  For example, you can work in the field with a low-cost Windows laptop and then transfer all 
work to a Mac desktop station, or to work with both Windows and Mac stations on the same 
network.  (However, not all media types are cross-compatible between Windows and the Mac OS.)

This paper will cover:

Part 1:  Acquiring And Archiving Footage To Be Edited.  Ways of acquiring P2 footage through 
shooting, from NLEs, from sharing files, or from content generated by P2 software and equipment, 
methods for archiving the footage before use in CS5, P2 file structure, and accessing footage on 
your computer.

Part 2:  Working In Adobe Premiere Pro.  Project setup, importing footage, working with the 
footage, and exporting to a variety of formats.  We will explore integration with Adobe Encore and 
After Effects through Dynamic Link.

Part 3:  Working In After Effects.  Importing footage, creating composites, working with the 
footage, and exporting through the render queue, as well as integration with Adobe Premiere Pro 
through Dynamic Link.

Part 4:  Adobe CS5 Production Premium HD Delivery Options.  Production Premium offers a 
wide array of HD delivery options, including P2 format, content for the Web, Blu-ray Disc authoring, 
and even export to HD tape for broadcast.

Part 1:  Acquiring and Archiving Footage to be Edited

Acquiring P2 Footage
The most common method for acquiring footage in P2 format is to shoot with any of the  Panasonic 
P2 and P2HD camcorders: the high-definition AG-HPX170, the AG-HVX200A, the AG-HPX300, the 
AG-HPX500, the AJ-HPX2000, the AJ-HPX3000, the AJ-HPX2700 and AJ-HPX3700 Varicams, or 
the standard-definition AJ-SPX800.  (Model numbers may vary slightly by region.)

The AVC-Intra codec is implemented by Panasonic in several of its P2HD broadcast cameras, 
including the HPX300, the HPX2000 (with optional AJ-YBX200 codec board), the HPX3000, and 
the HPX2700 and HPX3700 Varicams.

Footage may be acquired in other ways as well.  The AJ-HPM110 P2 Mobile six-slot recorder/
player, as well as the HPX300, HPX2000, HPX3000, HPX2700, and HPX3700 cameras, have the 
ability to create subclips or roughly-edited sequences from P2 footage stored on P2 cards, and to 
output them in P2 format to a P2 card.  Workflow with these types of clips will be the same as with 
any other method of acquisition.

Footage already shot may also be delivered on storage media such as hard disk drives, digital tape, 
optical media such as CD, DVD, or Blu-ray, or by any other file storage system.  As long as the P2 file 
structure is maintained, these files are identical to the files recorded on a P2 card.

Also, P2 footage may be created from the timeline of various NLEs, including Adobe Premiere Pro 
CS5, and then exported to P2 format as data files, or played out to a P2 camcorder and recorded 
directly to the P2 cards.
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As video is shot with a P2 camcorder, it is recorded to the P2 card.  The P2 card is a mass media 
storage device which is functionally identical to other storage devices like hard drives or flash 
drives.  The media files are stored in an IT file system with folders, subfolders, and a text file called 
“LastClip.txt” – this text file stores the file name of the last clip shot, and when transferring media to 
another drive, it should be kept along with the rest of the folders and files.

Next to the LastClip.txt file is a folder called “Contents.”  In it are six subfolders – Video, Audio, Clip, 
Icon, Proxy, and Voice.  These folders contain various files which make up the P2 data.  The Video 
folder contains the video portions of the footage, while the Audio folder contains the audio files.  
The Clip folder contains XML files which store the metadata recorded with each clip.  The Icon 
folder contains small .bmp thumbnail images of each clip.  The Voice folder contains audio files of 
any voice memos recorded with the clips (a function available on the HPX2000, HPX3000, 
HPX2700, and HPX3700 cameras as well as the P2 Mobile.  Voice memos can also be added in P2 
Viewer).  The Proxy folder contains low-res proxy video of the footage shot (again, available on the 
HPX2000/3000 and Varicam cameras and the P2 Mobile).

For the P2 system to function correctly, ALL folders and files must be kept intact and in their 
respective folders.  If they are not, vital information will be lost and the footage may not be usable.

Panasonic P2 Drivers And Software
Before working with P2 footage, download and install the P2 
drivers and P2 support software.  They can be found at http://
www.panasonic.com/business/provideo/p2-hd/downloads-and-
updates.asp.

The drivers will allow the computer to access and understand P2 
hardware, including the P2 cards themselves.  The support 
software, including P2 Viewer and P2 Contents Management 
Software (P2CMS), will provide a substantial set of tools for 
working with the P2 card contents.  (The Mac version of P2 Viewer 
is included with P2CMS.)

Archiving Footage
It is highly recommended that P2 data be archived before working with it.  The data on P2 cards is 
properly thought of as computer data, and not “video” data, and it should be archived accordingly, 
instead of to a form of video tape, including DVCPRO HD.  There are numerous archiving options.  
Whichever method you choose, be sure to keep the entire file structure intact and include the 
corresponding LastClip.txt file.  The best options include:

1.	 	Hard Disk Drives --  Transfer the P2 data just as you would any other data; this can be to an 
internal drive, but an external drive – whether over USB 2.0 or IEEE-1394 400/800 (FireWire) 
– would be most useful for long-term storage.

2.	 Optical Media -- The most useful variety will be Blu-ray Discs, because they are the highest-
capacity and can store multiple cards on a single disc, but standard DVD+/-R DVDs and 
dual-layer DVDs can be used to store single, smaller cards.

3.	 DLT or LTO tape --  Not video tape; DTO or LTO tapes are designed to store computer data 
instead of video footage, and can store hundreds of gigabytes per tape.

Hard Disk Drives
To transfer to hard disk drive, the best option is to use P2 Viewer (in Windows) or P2CMS (Windows 
or Mac).  This will allow you to create “virtual cards” with the correct file structure and all necessary 
files and folders intact, as well as mixing and matching clips from multiple cards as you see fit.  This 
will allow you the greatest flexibility and control over your archiving process.

http://www.panasonic.com/business/provideo/p2-hd/downloads-and-updates.asp 
http://www.panasonic.com/business/provideo/p2-hd/downloads-and-updates.asp 
http://www.panasonic.com/business/provideo/p2-hd/downloads-and-updates.asp 
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Or, you can simply copy over the existing folders and files of a card, making sure, as noted several 
times, to keep the file structure intact, including the LastClip.txt file.  You will need to create 
separate folders for each card, as each contains a Contents folder and LastClip file, and you cannot 
rename them and maintain P2 functionality.

To maintain functionality between Windows and Mac systems, a hard disk drive can be formatted 
as FAT32, which is compatible with both systems.  All P2 cards are formatted as FAT32, so any card 
will be able to be stored to a FAT 32 disk drive.  However, cards may also be stored on hard disk 
drives using the Windows NTFS or Mac HFS+ file systems.  For cross-platform access, Windows 
users can use software such as MediaFour’s MacDrive to read and write to Mac-format drives.  Mac 
users can read NTFS drives natively, but for read-write capability, additional software such as 
Paragon Software’s NTFS for Mac is required.

Optical Media
To archive onto optical media, you will need an appropriate DVD burner and burning software 
(such as Nero) to create data (not video) DVDs.  Again, you would maintain the P2  file structure 
and LastClip file.  You can burn a single 4 GB card to a DVD+/-R, a single 8 GB card to a dual-layer 
DVD, or multiple cards to a Blu-ray DVD, again creating separate folders for each individual card.

Archiving to DVD can also be done through Adobe Encore.  To do this, choose File>Select DVD 
ROM Folder, and then navigate to a P2 card; choose the folder level containing both the Contents 
folder and the LastClip.txt file.  Then go to File>Build and pick “Disc” from the submenu.  In the 
Build panel, you may choose the DVD size from 3.95 GB, 4.7 GB or 8.54 GB Dual Layer.  Under 
Output, choose “DVD Disc.”  When you click “Build,” choose “Ignore and Continue” when the box 
pops up warning there is a problem which may cause the disc not to play; it is unnecessary to make 
a playable video DVD.  After you click, the process will continue automatically with instructions.

Digital Tape
For archiving to digital data tape, Quantum offers DLT and LTO tapes and drive which specifically 
understand the P2/MXF file structure.  LTO-3 tapes are high-capacity and can store several 
hundred gigabytes of data.  Drives such as the Quantum LTO-3A and SDLT 600 are P2/MXF 
compatible.

Flash Media
Small cards can be stored on flash drives or memory cards of 4 GB or higher; however, the data 
rates and error rates for those cards may not be appropriate for direct editing from them, especially 
HD footage.  Cards stored on such drives should be transferred to hard disk before being used.  The 
process for transferring to a flash drive or memory card is the same as for storing to hard disk drive.  

Archiving To Video Tape
Footage can also be stored, with no quality loss, on video tape; DV/DVCPRO can be stored on DV 
tape.  DVCPRO HD, DVCPRO 50, and DVCPRO footage can be stored on DVCPRO tape.   

To archive on video tape from Adobe Premiere Pro, you can use File>Export>Export to Tape.  DV 
footage can be printed through 1394 with a DV deck or camcorder.  Printing to DVCPRO 50 or 
DVCPRO HD decks will require a hardware card, such as those from AJA or Blackmagic Design.  

Archiving to video tape will mean the loss of all metadata and will require linear capture for future 
use.  Footage originally recorded in 720p Native modes will be recorded to tape as “over-60” or 
“over-50” and will lose any space-saving or timeline advantages that the Native mode affords when 
on a P2 card.

For optimal performance, it is 
recommended to store the P2 data 
on hard drives in a striped RAID, 
allowing for increased transfer 
speeds, very useful for better 
playback performance of multiple 
streams and clips with added 
effects.
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Accessing P2 Footage On Your Computer
There are a number of ways to read P2 data within Adobe CS5 Production Premium:

Reading P2 Cards Directly
The quickest path to working with P2 footage would be to read the data directly from a P2 card – 
this can allow you to edit your footage literally seconds after shooting, with no waiting for capture 
or transcoding.  The footage is ready to edit as soon as it is recorded.

As the P2 card is a mass storage device, it can be read directly by either Windows or the Mac OS the 
same as any other storage device. Whichever method is used, in order to read a P2 card as a device, 
the computer must have the Panasonic P2 drivers installed.

Various options exist to connect a P2 card directly to a system.  The P2 camcorder itself can be 
used as a card reader when connected to the computer – through IEEE-1394 on a Mac and through 
USB 2.0 on a Windows machine. Likewise, an AG-HPG10 P2 Gear player/viewer/recorder may be 
used. (Using 1394 with Windows or using USB 2.0 with the Mac OS are not certified for complete 
functionality.)  A P2 Mobile in card reader mode will work as well.

An AJ-PCS60G P2 Store portable drive may also be used as a card reader over USB 2.0.  However, 
with the data transfer speeds involved, a more direct connection to the computer is recommended.

There are several options for a direct connection.  The AJ-PCD20 P2 Drive is a five-slot card reader 
which connects to the computer through USB 2.0 (not guaranteed in the Mac OS) or IEEE-1394.  
The P2 Drive has the advantage of reading all cards inserted as a single card, automatically stitching 
together any spanned clips between cards, and making the data on several cards accessible all at 
once.

Another way to connect a P2 card to a computer is through a PCMCIA slot.  The P2 card conforms 
to the 32-bit CardBus standard, so it can be read with any reader which is capable of reading that 
standard.  Many laptops are equipped with this slot.  For desktops, there are PCI-to-PCMCIA 
adapter cards available which will allow direct connection.  Again, the reader must conform to the 
32-bit CardBus standard in order to be used with a P2 card.

A laptop with an ExpressCard reader may also be used with a PCMCIA adapter, such as the 
DuelAdapter available from Duel Systems or the Addonics ADEXC34CB.  Again, the P2 driver and 
support software must be installed.  (Check with the adapter manufacturers for driver updates for 
compatibility with OS system updates.)

Another method for connecting a P2 card to a system which does not have a PCMCIA slot is to 
network with a laptop with such a slot over a Gigabyte-E network port.  Once connected and set 
up, the laptop’s card slot will act as though it is a slot integrated directly into the system, with data 
transfer speeds comparable to a direct connection.  However, a slower connection, such as with a 
10/100 “Fast Internet” port, will not have comparable transfer speeds.

Using any of these methods, Adobe Premiere Pro, After Effects, Adobe Encore, and OnLocation 
CS5 can read, import, and edit the footage on the cards exactly as if it were stored on a hard disk 
drive.

Offloading Cards To Hard Disk
P2 cards may also be offloaded to hard disk drive and accessed by Adobe CS5 Production Premium 
applications as any other files.  Files may be transferred directly from the card to an internal or 
external hard drive using any of the methods above to connect the card to a computer, and then 
using the computer’s operating system to transfer the files.  For a direct transfer, it is vitally 
important that both the Contents folder and the LastClip.txt file are saved together and completely 
intact; creating a new folder for each P2 card will allow for this.
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It is highly recommended, though, that instead of a direct transfer of files through Windows 
Explorer or Mac Finder, P2 cards should be offloaded using P2 Viewer or P2CMS.  These programs 
allow for greater control and monitoring of the transfer process, and offer the stitching of spanned 
clips.  You can also use them to group clips as you wish and create new P2 cards which can then be 
transferred back to a physical P2 card, or used as P2 data with CS5 Production Premium and other 
P2-aware applications.

Direct access of P2 data is the same whether you read from the P2 card or from a hard disk or other 
storage device – you use Windows Explorer or Mac Finder to navigate to the drive, and then to the 
specific card volume, where you can access any of the data in the P2 Contents folder or subfolders.  

You are now ready to import the P2 data into a CS5 Production Premium application.

Part 2:  Working In Adobe Premiere Pro

Adobe Premiere Pro Project Setup
When opening Adobe Premiere Pro, you will be asked to create a new project, or open an existing 
project.  If you create a new project, you will then be asked to create a sequence.

It is not necessary to create a sequence before entering Adobe Premiere Pro.  It is, however, 
necessary to create a sequence before you can begin work, so it is recommended that you create a 
sequence at this time.  

You may create multiple sequences with any settings and group them together into a single 
sequence of any settings.  So, you may work in one sequence with settings for 720p and in another 
with settings for 1080i -- even at different frame rates -- but you may nest either sequence into the 
other, or you may nest them both into a third sequence of even different settings.  How close to real-
time playback you are able to achieve will depend upon your system hardware.

If you do not create a sequence when opening the project, you can create one by pressing 
Control+N (Windows) or Command+N (Mac), or by right-clicking, or Control+clicking (Mac), in 
the Project panel and choosing “New Item>Sequence.”  You will then be given options for project 
presets; groups of presets will appear in the “Available Presets” box of the “New Sequence” panel, 
represented as file folders.

Sequence Settings
For P2 material, there are a number of preset options.  Your best option is to choose a sequence 
setting which fits most, if not all, of the footage you will be using in the project.

DVCPROHD 720p -- for High Definition material, the project preset should be chosen according to 
the frame rate.  In the DVCPROHD folder, there is a subfolder labeled “720p” containing the 720p 
presets.

•	 For 720/24p (N or “P”) footage:  choose DVCPROHD 720p24

•	 For 720/60p footage:  choose DVCPROHD 720p60

•	 For 720/50p footage:  choose DVCPROHD 720p50

There is no preset for 30pN, but you can either edit as 60p, or you can modify the preset in the 
General tab.  There, you would go to the Timebase dropdown and select “29.97 frames/second.”  

For 25pN footage, select the 50p preset, and change the Timebase to 25.00 frames/second. 

For 30P (not Native) and 25P (not Native), you should edit as 60p and 50p, respectively, or you can 
create the specific timebase settings for the frame rates.
  
For Native-mode variable frame rate footage, choose (or create) the preset which matches the 
timebase the clip was recorded in – 24p, 25p, 30p, 50p, or 60p – as opposed to the variable frame 
rate (12 fps, 22 fps, 36 fps, etc.).  In the Native mode, the footage is already recorded in its Native 
frame rate; nothing needs to be done with it when working in a matching sequence.

All DVCPROHD frame sizes and frame 
rates are grouped together.
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DVCPROHD 1080i/p -- like 720p, there is only one frame aspect ratio for 1080 footage – 16:9.  There 
are two subfolders for 1080 footage under DVCPROHD -- “1080i” and “1080p.”  (See inset above.)

•	 For 1080/24p or 24pA footage, choose DVCPROHD 1080p24.

•	 For 1080/60i footage, choose DVCPROHD 1080i60

•	 For 1080/50i footage, choose DVCPROHD 1080i50

Again, for 1080/30p and 1080/25p, there are no presets, but they can edited as 60 Hz or 50 Hz, or 
presets can be created by following the same methodology as with the Standard Definition presets 
below.

AVC-Intra 720p -- the sequence Presets for AVC-Intra 720p footage are contained in a single folder.

As with DVCPRO HD footage, choose the preset which best matches your footage.  For variable 
frame rate footage, select the preset according to your overall timebase.

1.	 AVC-Intra 100

•	 For 720/60p footage, choose AVC-I 100 720p60.

•	 For 720/50p footage, choose AVC-I 100 720p50.

•	 For 720/30p footage, choose AVC-I 100 720p30.

•	 For 720/25p footage, choose AVC-I 100 720p25.

•	 For 720/24p footage, choose AVC-I 100 720p24.

2.	 AVC-Intra 50

•	 For 720/60p footage, choose AVC-I 50 720p60.

•	 For 720/50p footage, choose AVC-I 50 720p50.

•	 For 720/30p footage, choose AVC-I 50 720p30.

•	 For 720/25p footage, choose AVC-I 50 720p25.

•	 For 720/24p footage, choose AVC-I 50 720p24.

AVC-Intra 1080i/p -- the Presets for 1080 material are split between 1080i and 1080p.  As there is 
no 60p or 50p recording in 1080 mode, the only 60 Hz and 50 Hz presets are for 60i and 50i.

All available frame rates for 1080i in both AVC-Intra 100 and AVC-Intra 50 are in the 1080i folder.  All 
available frame rates for 1080p in both AVC-Intra 100 and AVC-Intra 50 are in the 1080p folder.

Choose your preset according to the bitrate and frame rate of your footage.

3.	 AVC-Intra 100

•	 For 1080/60i footage, choose AVC-I 100 1080i60.

•	 For 1080/50i footage, choose AVC-I 100 1080i50.

•	 For 1080/30p footage, choose AVC-I 100 1080p30.

•	 For 1080/25p footage, choose AVC-I 100 1080p25.

•	 For 1080/24p footage, choose AVC-I 100 1080p24.

4.	 AVC-Intra 50

•	 For 1080/60i footage, choose AVC-I 50 1080i60.

AVC-Intra Sequence Presets
There are two sets of bitrate presets 
from which to choose -- 100 Mbps and 
50 Mbps.
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•	 For 1080/50i footage, choose AVC-I 50 1080i50.

•	 For 1080/30p footage, choose AVC-I 50 1080p30.

•	 For 1080/25p footage, choose AVC-I 50 1080p25.

•	 For 1080/24p footage, choose AVC-I 50 1080p24.

Standard Definition (DV, DVCPRO, and DVCPRO50) -- Standard Definition footage can have two 
frame aspect ratios:  4:3 (standard) or 16:9 (widescreen).  It is important to choose the correct ratio 
from among the sequence options.

With DV or DVCPRO (25) footage, you will use the same presets.  There are three separate preset 
folders:  DV-24p, DV-NTSC, and DV-PAL.  Choose the folder according to your footage – for 24p DV, 
choose DV-24p; for 60i or 30p DV, choose DV-NTSC; for 50i or 25p DV, choose DV-PAL.

Each group includes four presets -- two standard, two widescreen; the difference between the two is 
the audio sample rate.  Under almost all circumstances, choose the template with the 48 kHz sample 
rate instead of the 32 kHz.  If you did happen to record in the 32 kHz rate, choose that option only if 
no other footage with 48 kHz sampling will be in the project.

So, for individual types of footage, make the following choices: 

•	 For 24p or 24pA footage:  choose DV-24p, Standard or Widescreen, 48kHz
•	 For 60i footage:  choose DV-NTSC, Standard or Widescreen, 48kHz
•	 For 50i footage:  chose DV-PAL, Standard or Widescreen, 48kHz
•	 30p footage:  there is no preset, but you can either simply choose DV-NTSC, Standard or 

Widescreen, 48 kHz, and edit in that sequence, or you can choose that preset and modify it by 
going to the General tab, finding the “Fields” drop-down menu in the Video box, and changing 
from “Lower Field First” to “No Fields (Progressive Scan).”  

You may then click “Save Preset” at the bottom of the box and name it as you wish.  It will then 
appear under the Custom folder in the Available Presets menu.

25p footage:  similar to 30p, there is no preset, but you can chose DV-PAL, Standard or Widescreen, 
48 kHz, and make the same change and save it as a Custom preset if you wish.

For DVCPRO 50 footage, all presets are contained in the same folder.  There are two subfolders, 480i 
(for NTSC) and 576i (for PAL).  In these two folders are the presets you will choose from.

•	 For 24p or 24pA footage:  choose 480i, DVCPRO50 24p Standard or Widescreen.

•	 For 60i footage:  choose 480i, DVCPRO50 NTSC Standard or Widescreen

•	 For 50i footage:  choose 576i, DVCPRO 50 PAL Standard or Widescreen

As with DV, there are no default presets for 30p or 25p, so you can either use the NTSC or PAL 
standard presets, respectively, or you can create progressive presets by again going to the General 
tab and changing the Field Order to “No Fields (Progressive Scan).”  

Importing Footage Into Adobe Premiere Pro
There are three ways to import P2 data into Adobe Premiere Pro CS5.  You may import footage 
before creating a sequence. 

The Media Browser
The best method for importing clips is using the Media Browser panel.  The media browser will allow 
you to view thumbnails of the P2 media, will show the user-friendly clip name, and will provide full 
support for clip spanning and card spanning.

In it, you will see a list of your storage devices; clicking on the arrow next to each letter will reveal 
the folders on that drive.  Navigate by clicking the disclosure triangles to a folder containing a P2 
card (“twirling to a folder”) – or to a P2 card itself if mounted on the system – and in the sub-panel 
immediately to the right, thumbnails of your clips will appear.  (If the thumbnails do not appear, 

Progressive and interlaced presets are 
grouped separately, and then by 
bitrate.

DV Presets
24p presets are contained in their own 
folder.
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select View As: Panasonic P2.)

UserClip Name  -- if a UserClip Name is assigned in the P2 metadata, it will be displayed in the Name 
column instead of the 6-digit identifier assigned by the camera. (If no UserClip Name is assigned, the 
Media Browser will display the long GlobalClipID.)  

Shot Mark -- the P2 metadata Shot Mark corresponds with the Good column in the media browser, 
the Project panel, and wherever the Good column appears.  If a P2 clip carries a Shot Mark, the word 
“Yes” will appear in the Good column.  (In the Project panel; it will appear as a check mark in the 
box.)  If you tag the clips you wish to use with Shot Marks in camera on the shoot, or in P2 Viewer 
-- for example, using the Shot Mark as a “circle take” function -- you can sort them on the Good 
column and import only those clips as a group. 

You can also sort the clips by any of the metadata columns, so if you wish to group your clips by Clip 
Name, or frame rate, or any other of the applicable columns, you may do so before importing.  If 
you have, for example, assigned UserClip Names according to scene number, with incremental take 
numbers, in the P2 metadata, the clips can be sorted accordingly before you decide which to import.

To the right of the clip thumbnail and the clip Name, you will see numerous columns of metadata.  
You can select which columns are displayed, and in what order, by clicking on the flyout menu icon 
in upper right of the Media Browser panel, and choosing “Edit Columns.” 

To import a clip from the media browser into Adobe Premiere Pro directly, you can drag a thumbnail 
to the Project panel, or you can right-click and choose “Import.” Continuous takes split into 4 GB 
clips, or spanned over cards, when recorded will be imported as a single clip automatically.

If you wish to review clips before deciding to import them, a clip in the Media Browser can be 
opened in the Source panel only – without importing into the project -- by double-clicking.  There, 
you can set in/out points and then send the selection only to the timeline.  You can drag/drop 
the selection by cursor, or, you can send the clip to the Current Time Indicator on the timeline by 
pressing the comma key for an Insert edit, or the period key for an Overlay edit.  You can also click 
the corresponding edit buttons under the Source panel.  The selection will appear in the timeline, 
and the full clip will automatically be imported into the project.

File>Import
You may also use the Import selection under the File Menu (or Ctrl+I in Windows or Command+I on 
the Mac).  In the Import dialogue box, you would then navigate to the Video folder of a P2 card and 
select the MXF files for import.  As with the drag/drop method above, the corresponding audio files 
will be linked automatically.  This method does not provide support for linking spanned clips.  
	

P2 clips on a P2 Card as they 
appear in the Media Browser, 
displaying UserClip Names as 
defined in the P2 metadata  
(such as ‘Yes’ values in the 
Good column denoting clips 
with Shot Marks.)

.
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Drag And Drop
You may also use Windows Explorer or Finder to navigate to the Video folder of a P2 card.  Then, you 
may simply drag the video files to the Project panel in Adobe Premiere Pro, which will automatically 
link the video to the corresponding audio files in the Audio folder.  (If you navigate to the Audio 
folder and import a single MXF audio file, the corresponding video will not be imported with the 
audio – but all corresponding audio MXF files will be brought to the timeline with that MXF file.)  
This method, too, will not link spanned clips.

Working With Footage In Adobe Premiere Pro

Working With Metadata
Adobe Premiere Pro CS5 has powerful tools for media management by working with the metadata 
stored with each clip.  At its most basic, all of the metadata stored with a P2 clip can be viewed 
simply by right-clicking or Control-clicking a clip in the Project panel and choosing “Properties.”  The 
Properties panel will open and all metadata can then be viewed.  

Under the Window menu, the Metadata panel can be activated.  The panel is divided into three 
sections – Clip, File, and Speech Analysis.  The Speech Analysis section will display the text transcript 
of the spoken words in the audio if the clip has been analyzed with the Analyze Content tool, as 
mentioned below.

Many metadata fields in the Clip and File sections may be edited.  The data will be saved and 
viewable as an XMPTM file created to be associated with the clip.  This XMP data is viewable in other 
applications which support XMP, including all the other applications in the Creative Suite.  Thus, the 
changes made are viewable, and the metadata is editable, in other CS5 applications such as After 
Effects and Encore.  The XMP files are saved in the Clip folder of the P2 card.  No changes will be 
made to the P2 card’s XML files.

Not all metadata from the P2 card is viewable or editable in the Metadata panel, or in the project 
or Media Browser panel columns.  Also, many of the metadata fields in the XMP files/viewer do not 
correspond with P2 metadata items.

Working With Media In The Project Panel
All project media files appear in the Project panel.  The media files can be listed entirely as separate 
items, or they can be organized into a file/bin structure for ease of media management.

Multiple P2 clips which comprise a single take will be “stitched” in the Project panel and display as a 
single clip.  This is true of clips spanned over multiple cards, and also of multiple clips from the same 
P2 card which are split because they exceed the 4 GB file size limit of FAT32.

As in the Media Browser panel, if a UserClip Name is assigned in the P2 metadata, P2 clips are 
displayed with the clip names corresponding to the UserClip Names, and not with their universal 
6-digit file names assigned by a P2 camera.  If no UserClip Name is assigned, the clip name in the 
Project panel will be the 6-digit name.  If a clip carries a Shot Mark in the metadata, the box in the 
Good column will be checked.

Media items are listed with numerous columns of metadata.  The default set of columns is the 
legacy display of information common to previous versions of Adobe Premiere Pro, but they can 
be deselected, or more/different columns added, by clicking on the flyout menu icon in upper right 
of the Project panel, and choosing “Metadata display.”  Column order can be changed by dragging 
columns.

In the Metadata Display panel, you can choose which columns to display by checking or unchecking 
their boxes.

The project can be sorted on any of the columns.  Some of the metadata in the columns can be 
edited directly in the Project panel; changes will be saved to the XMP file.

Audio Channel Mapping
A particularly useful tool when working with AVC-Intra, DVCPRO HD, or DVCPRO 50 footage 
with four mono channels of audio is found in the Clip menu.  Under Modify is a submenu with the 
selection “Audio Channels.”  

Here, you can assign the audio tracks associated with a clip to stereo, mono, or 5.1 tracks, instead 
of the four mono tracks the footage would normally have.  If you recorded your main audio only to 

Adobe has created a Workspace 
configuration called “Metalogging” 
which is useful when browsing 
and importing footage using 
the Media Browser.  Go to 
Panel>Workspace>Metalogging, 
or Alt+Shift+5 (Windows) or 
Option+Shift+5 (Mac).
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channels 1 and 2 of your footage, and channels 3 and 4 are blank, you can select “Stereo” from the 
radio button choices on the left side of the dialogue box.  Channels 1 and 2 will be assigned to a new 
stereo track, Track 1, with Channel 1 being the left channel, and Channel 2 being the right channel.  
(If you wish, you can switch this arrangement by dragging the speaker icon from track into the other.)  
Channels 3 and 4 will be assigned to the left and right channels of a stereo Track 2.  You can then 
uncheck the “Enable” boxes to the left of Channels 3 and 4, and they will disappear from the Track/
Channel diagram.

When you send the clip into the timeline, by dragging or through the Source panel, Channels 1 and 
2 will now be brought in as a single, stereo track, whereas without mapping the channels, the audio 
would always be brought in as four mono tracks.

You may choose to group the channels differently by dragging the track number/left-right icons; any 
combination is possible, including choosing only one active mono track.

This process may be applied to multiple clips at once by selecting them all in the Project panel 
before opening the mapping tool.

Speech Recognition with Speech Search
Speech Search is a feature in Adobe Premiere Pro that turns spoken dialogue into text-based, 
timecode-accurate, searchable metadata.  You can jump to a specific area of a shot by searching 
for keywords within the dialogue, and then use keywords to quickly locate and display what you’re 
looking for — or even cut video based on the script. 

To use Speech Search, select Analyze Footage in the Clip menu.  Using this tool, a clip’s audio is 
scanned and transcribed to text which then becomes part of the clip’s XMP file.  This text is fully 
searchable, and can be used, for example, to find and skip to specific words within a clip.  If there 
are multiple speakers and there is enough difference between their voices, the tool can identify the 
individual speakers in the transcript.  The speech analysis works better the more clear the spoken 
words are; the transcript can be edited manually.

Working With 24p/Pulldown Removal
Adobe Premiere Pro has comprehensive support for all modes of 24p recorded by P2 camcorders.

DV/DVCPRO/DVCPRO HD -- with 1080/24p footage, Adobe Premiere Pro will automatically detect 
the pulldown flags embedded in the footage, whether recorded with standard 2:3 pulldown (24p), 
or with 2:3:3:2  Advanced pulldown (24pA).  In a 24p sequence, either version of pulldown will 
be removed automatically, and the footage properties will recognized as having a frame rate of 
23.976.  On the timeline, you will be working the native 24p frames only.  In a 59.94i sequence (also 
known as 60i, 30i, or standard 29.97 interlaced), the pulldown will not be removed, and the footage 
properties will read as 29.97.  Most of the time, you will want to work in a 24p sequence with the 
pulldown removed, but if you are mixing the footage in a sequence with footage of other frame 
rates, it is often best to work in 59.94i.

With 480/24p material, whether DV, DVCPRO, or DVCPRO 50, Adobe Premiere Pro functions the 
same as with 1080, whether the material was shot with standard or advanced pulldown, detecting 
and removing the pulldown in 24p sequences and leaving it in place in 60i sequences.

For footage shot in the 720/24P (non-Native) mode, which are recorded in 60p streams, Adobe 
Premiere Pro will automatically remove the duplicate pulldown frames and work with the footage 
as native 23.976p.  Adobe Premiere Pro will also recognize 720/30P and 720/25P (again, non-
Native mode) at their native frame rates, removing duplicate frames from the “over-60” or “over-50” 
streams. 

In order to edit and save the XMP 
metadata, including making a 
speech transcript, it is important 
to make sure any write protection 
is disabled.  In Windows, uncheck 

“Read Only” in the Contents 
folder Properties, and make sure 
it applies to all subfolders and 
files.  In the Mac OS, make sure 
the Contents folder’s Ownership 
& Permissions is set to “You Can 
Read & Write.” 



12Adobe CS5 Production Premium Panasonic P2

 A 720 “P”-mode 24p-over-60p clip with pulldown removed automatically.

Working With 24pN, 25pN, and 30pN -- no pulldown removal or footage interpretation is required 
for footage shot in the DVCPRO HD720 native “N” modes; those modes are recorded in their native 
timebases with no pulldown.  This includes variable frame rate footage. 

AVC-Intra -- in AVC-Intra, as all frame rates are recorded as Native, there are no over-60 or over-
50 recording modes.  Therefore, with AVC-Intra footage, there is never any pulldown or any extra 
frames to remove.  

Working With Variable Frame Rates
When using variable frame rates in AVC-Intra or in the DVCPRO HD 720 Native modes, these, too, 
are recorded on a per-frame basis in the overall frame rate you select.  If your overall frame rate 
is 24p, and your variable frame rate is 12 fps, those 12 frames per second will be line up, frame-
for-frame, as 24 frames per second.  When played back from the Native file, the footage will play 
back twice as fast as real-time.  Frame rates lower than 24 will have the same, but lesser, effect.  If 
your variable frame rate is higher, the 23.976 file recorded will play back with slow motion, with 
the motion slower the faster your variable frame rate is.  There is no need to use Interpret Footage 
or change the playback rate of the clip; as the clips are recorded as 23.976, all apparent speed 
adjustments have already been done while recording.  The same principle applies all frame rates.

Editing Footage in Adobe Premiere Pro
Footage can be edited either directly from the P2 cards, as noted before, or from a hard disk drive.  
With a fast, modern processor and at least 2 GB of RAM, Adobe Premiere Pro can edit multiple 
streams of HD footage at real time, and performance is much faster in Adobe Premiere Pro CS5 
thanks to the revolutionary Mercury Playback Engine, which delivers native 64-bit support, GPU 
acceleration, and other performance and stability improvements (see Previewing below).   With the 
Mercury Playback Engine, you can edit HD as fluidly as SD: open projects faster, refine effects-rich 
HD and higher-resolution sequences in real time, enjoy smooth scrubbing and play back of complex 
projects without rendering.  See results instantly when applying multiple color corrections, the new 
Ultra Keyer, Gaussian blurs and blend modes, and work with numerous other effects across many 
video layers.   With industry-leading performance and rock-solid stability, you can work in real time 
on complex timelines and long-form projects with thousands of clips – whether your project is SD, 
HD, 2K, 4K or beyond.

Editing from DVD or optical media is not recommended; the data transfer speeds from the drive will 
be too slow for effective editing.

Generally, any type of supported media may be dropped into a timeline of any sequence settings 
without any sort of transcoding or rendering.  A red bar may appear above footage which does not 
conform to the sequence settings; this means that the footage must be rendered for final output, 
but (pre)rendering isn’t necessary for playback on the timeline.  Timeline playback may not be full-
quality or without dropped frames, however.  (If you wish to render for full-frame rate playback, 
press Enter, and Adobe Premiere Pro will create a rendered file and replace the footage with it.)

A yellow bar indicates that a clip does not match the settings of the sequence, but can generally still 
be played back in real-time without rendering.  A green bar indicates that all necessary rendering is 
completed.
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AVC-Intra10-bit Footage
AVC-Intra is a 10-bit codec, utilizing four times as much luma and chroma depth per pixel as 
standard 8-bit codecs.  This allows for a great deal more precision and quality in the footage.

To take advantage of the full 10-bit quality of AVC-Intra footage, in the sequence settings, check the 
Maximum Bit Depth box in the Video Preview section of the General tab.  This will require greater 
processor resources, so this is recommended only for powerful computers.

Previewing To An External Monitor
Previewing a project is not limited to the preview panel in Adobe Premiere Pro.  There are several 
options for an external preview.  This offers numerous advantages.  The entire video frame can 
be seen at full size, allowing for more detailed work; the project can be sent to the type of screen 
which will be the intended primary viewing source, such as an NTSC or PAL monitor or an ATSC 
High-Definition monitor, allowing an accurate representation of the picture for purposes of image 
manipulation, particularly color correction.  It can be easier for display of a work-in-progress to a 
client or a group of people, etc.  In general, it allows you to see your work as closely as possible to 
how your audience will see it.

All preview options are found by clicking the Output button under the preview panel, then choosing 
“Playback Settings . . .”  

From there, you will be given a dialogue panel; external preview options are found in the “External 
Device” drop-down menu in the “Realtime Playback” box.

For most projects, the preview can be sent as DV via 1394 through a DV camera or deck to a 
monitor, through composite or S-Video cables/inputs.  This is ideal if working in a DV or standard-
definition project, but it is not ideal if working in HD.  HD material in either version can be previewed 
using an HD preview card, such as AJA’s Kona (Mac) or Xena (Windows) cards, or Blackmagic 
Design’s DeckLink or Intensity Pro cards.

Preview is accelerated using a Mercury Playback Engine-supported NVIDIA graphics card (GPU).  The 
GPU can accelerate video playback with heavy effects to real-time if the card is powerful enough, 
depending on the footage type and level of effects.  This can be very useful when working with high-
bandwidth footage like DVCPRO HD or AVC-Intra. Playback is also enhanced by OpenGL support 
with some effects.

The Windows version of Adobe Premiere Pro can also use the graphics card to preview on an 
external HD monitor if the card has a native HDMI output port, or through a DVI output using a 
DVI-to-HDMI adapter.  For this, you must use the GPU’s driver software to set up the output as a 
Windows display.  Then, you should see that display as an option in the External Device drop-down.

Exporting Footage From Adobe Premiere Pro
Exporting a sequence can be done in several ways.

As P2 Format
Adobe Premiere Pro can create virtual P2 cards through Adobe Media Encoder, or by direct export.

Choose File>Export>Media, then choose “P2 Movie” in the Export Settings panel.  There are many 
P2 format options available in the Preset drop-down menu.   Choose your desired preset. 

Export Through Adobe Media Encoder -- at the bottom of the Export Settings box are two buttons 
-- “Queue” and “Export.”  If you press “Queue,” Adobe Media Encoder will open.  Pressing “Start 
Queue” in Media Encoder will begin the process; the timeline will be rendered and exported as a 
virtual P2 card, creating all necessary folders and files in the correct P2 file structure.  A Contents 
folder will be created, holding all six subfolders.  Video and Audio will be separated into MXF files 
and placed into the appropriate folders.  All active audio tracks will be mixed down to stereo and 
saved in the Audio folder as two mono tracks representing left and right.  (Only the two mono tracks 
will be included, regardless of format.)

This virtual card can be exported directly to a connected P2 card, or it can be exported to a selected 
drive and the folders and files copied over to the card.  It can also be opened as a virtual card using 
P2 Viewer or P2CMS software and worked with as any other P2 card or virtual card.

Each export to P2 will result in a single clip.  Multiple clips can send to the same Contents folder by 
defining the output folder to the level above it.  For example, if the output folder is C:\Card Output, 

The Mercury Playback Engine works 
hand-in-hand with NVIDIA® CUDA™ 
technology and the following 
graphics cards are now available:
 
•	 Quadro CX (Windows)
•	 Quadro FX 3800 (Windows) 
•	 Quadro FX 4800 (Windows 

and Mac) 
•	 Quadro FX 5800 (Windows) 
•	 GeForce GTX 285 (Windows 

and Mac) 

Please see www.nvidia.com 
for system requirements and 
compatibility.  

Adobe is planning on supporting 
additional cards as they become 
available, including some of the 
new NVIDIA solutions based on the 
upcoming Fermi parallel computing 
architecture. For an up-to-date list 
of supported cards, please see www.
adobe.com/go/64bitsupport.

http://www.nvidia.com
http://www.nvidia.com/object/fermi_architecture.html
http://www.adobe.com/
http://www.adobe.com/
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a Contents folder will be created in the Card Output folder.  Multiple P2 exports to Card Output 
will result in new MXF clips being added to the existing Video and Audio folders, as well as the 
associated files in the Clip and Icon folders.  The clips will be assigned separate 6-digit file names as 
they would in-camera.

Exporting to P2 format can be combined with multiple media format exports from Adobe Media 
Encoder, as described below.  

Direct Export -- if you press “Export” instead of “Queue,” you may export directly to P2 format 
without going into Adobe Media Encoder.

Other Formats Via Adobe Media Encoder
To export a completed movie file, go to File>Export>Media, and then choose the desired format 
in the Export Settings box.  Click “Queue,” and then Adobe Media Encoder will open, and the 
project will appear as a selection in the Source panel.  From here, the output format settings may be 
changed, or multiple format settings may be added.  

When encoding is started by pressing “Start Queue,” a movie file in the desired format will be 
created; multiple files will be created if multiple settings selections are made.

As with P2 format, other formats may also be exported directly by selecting their presets and 
settings and pressing “Export” instead of “Queue.”

Exporting To Other CS5 Applications Via Dynamic Link
An Adobe Premiere Pro project may be sent to Encore or opened as a new composition in After 
Effects by going to File>Adobe Dynamic Link and choosing the appropriate selection.  The chosen 
application will then launch and the Adobe Premiere project will appear in the Project panel of the 
application.  

Edits, transitions, and clip effects will be preserved when opened in the other applications.  Any 
changes to the sequence made in Adobe Premiere Pro will be immediately reflected in the other 
applications.

Opening Adobe Premiere Pro Project Files In Other CS5 Applications
After Effects and Encore have the ability to open Adobe Premiere Pro .prproj files, including P2 
projects.  A .prproj file can be opened directly in After Effects by going to File>Import>Adobe 
Premiere Pro project and navigating to a .prproj file.   An Adobe Premiere Pro sequence can be 
opened at File>Adobe Dynamic Link>Import Adobe Premiere Pro Sequence and navigating to a 
.prproj file.  All the sequences in the Adobe Premiere Pro project will then be displayed and can be 
chosen from. 

A .prproj file can be opened in Encore through File>Adobe Dynamic Link>Import Adobe Premiere 
Pro Sequence and again navigating to the file.  As with After Effects, the sequences associated with 
the Adobe Premiere Pro project will then appear and can be chosen from.

Part 3:  Working With P2 Footage In After Effects

After Effects, the industry-standard compositing, motion graphics and visual effects program, 
supports P2 material natively.  It supports all P2 formats and frame rates.  After Effects can accept 
the P2 files directly in a stand-alone composition, or it may accept Adobe Premiere Pro P2 projects 
or sequences via Dynamic Link, or by opening them directly from the .prproj file.

Importing Footage Into After Effects
P2 material can be imported by going to File>Import and then navigating to the Video folder of a 
P2 card, or by dragging/dropping the MXF files from the folder into the Project panel.  If a single, 
continuous take was split into 4 GB sections when recorded, the separate clips will be imported as a 
single clip.

After Effects Project Setup
The equivalent to a sequence in Adobe Premiere Pro is a composition in After Effects.  If you have 
imported your footage into the project before creating a composition, you can simply drag a 
footage asset to the Create a New Composition square at the bottom of the Project panel.  This will 
automatically create a composition which matches the properties of the footage.  

Note:  export to P2 format will 
result in two channels of audio, not 
four.  All audio tracks will be mixed 
down to stereo and exported as 
mono (left and right) tracks.

Note:  Dynamic Link between After 
Effects and Adobe Premiere Pro is 
only available with the Production 
Premium or Master Collection 
Suites; it is not available if the 
products are purchased separately.  

Dynamic Link between Adobe 
Premiere Pro and Encore is 
included with standalone Adobe 
Premiere Pro, Production Premium 
and Master Collection.
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To create a composition manually, go to Composition>New Composition.  A dialogue box will 
appear in which you can define the attributes of the composition, including frame size, frame rate, 
etc.  There are numerous presets available.  As with Adobe Premiere Pro, choose the preset which 
best fits your footage, or define your own composition settings manually.

Working With P2 Footage In After Effects

Working With 24p Pulldown
After Effects can work with files of any frame rate.  However, for frame rates shot in “over-60” modes, 
such as 24p with pulldown in 60i or 60p streams, the files must be manually converted to the native 
frame rate by right-clicking or Control-clicking and choosing Interpret Footage, as described in 
Adobe Premiere Pro above, then choosing “Main.”

From there, in the “Fields and Pulldown” box, you can choose to remove the type of pulldown in 
the footage, 3:2 pulldown (standard) or 2:3:3:2 pulldown (“24P Advance”).  If the Remove Pulldown 
drop-down is blank, you can choose from the “Guess 3:2 Pulldown” or “Guess 24Pa Pulldown” 
buttons underneath, depending on whether you shot with standard 3:2 pulldown or with Advanced 
pulldown.  (Footage shot in the 720P/24P “over-60” mode will always use 3:2 pulldown.)  

Or, you can enter the frame rate manually in the “Conform to frame rate” box.

Integration With Adobe Premiere Pro
After Effects integrates with Adobe Premiere Pro in a number of ways.

Importing Adobe Premiere Pro Sequences  -- As noted above (p. 20), After Effects can open Adobe 
Premiere Pro .prproj files directly.  When opened, all of the Adobe Premiere Pro project media and 
sequences will appear in the Project panel of After Effects. 

Dragging an Adobe Premiere Pro sequence to a composition timeline will open that sequence on 
the timeline.  All media will appear in the same arrangement as it does in the Adobe Premiere Pro 
sequence, and will preserve some effects and transitions applied in Adobe Premiere Pro.

(Opening an Adobe Premiere Pro project in After Effects is the same as copying/pasting between 
Adobe Premiere Pro and After Effects; see Copy Between After Effects and Adobe Premiere Pro in 
Adobe After Effects Help for a list of preservations and conversions.)

Using Adobe Dynamic Link -- in Adobe Premiere Pro, an option exists under File>Adobe Dynamic 
Link to “Create New After Effects Composition”, which will launch After Effects, and create a new 
composition.  That composition will be linked to the Adobe Premiere Pro project as a composition 
which appears in the Project panel.  That composition may be dropped into an Adobe Premiere 
Pro sequence as a self-contained clip.  Any changes made in the composition in After Effects will 
automatically be reflected on the timeline in Adobe Premiere Pro.

Likewise, in the After Effects File menu, a choice under Adobe Dynamic Link is “New Adobe 
Premiere Pro Sequence.”  Here, a sequence will be created in Adobe Premiere Pro and appear as 
“Linked Sequence” in the After Effects Project panel.  Any changes made to the sequence in Adobe 
Premiere Pro will be automatically reflected in the composition in After Effects.

Also available is the ability to open selected clips in the Adobe Premiere Pro timeline in After Effects 
and replace them automatically with an After Effects composition.  In Adobe Premiere Pro, select 
the desired clips, then right-click or Control-click one of them and select “Replace With After Effects 
Composition.”  After Effects will then launch and a new composition will automatically be created 
with the selected clips already on the composition timeline.

In Adobe Premiere Pro, the selected clips will then show as a single clip.  Changes made to the clips 
in the composition will be reflected on the Adobe Premiere Pro timeline each time you return to 
Adobe Premiere Pro.  Clips formerly occupying multiple tracks will now appear on a single track, and 
there will be a red bar.

Rendering and Exporting Footage From After Effects

As A Movie File
To export a movie from After Effects, use the Render Queue.  You can access the Render Queue by  
going to Composition> Add to Render Queue.  Here you can select from many formats and format 
settings, or add multiple formats and settings to create multiple movie files of multiple formats.
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As an Adobe Premiere Pro Project
A choice in the File>Export menu is “Adobe Premiere Pro project.”  This will allow you to export an 
After Effects project in Adobe Premiere Pro format.  The resulting .prproj file can then be opened 
in Adobe Premiere Pro; a folder will appear in the Project panel containing all of the media in the 
project, and each composition will appear as a separate clip.  Compositions can then be added to a 
sequence timeline as a self-contained clip.

Part 4:  Overview of Production Premium HD Delivery Options

There are several common methods for delivering HD content: exporting for web content, for high-
definition DVD delivery, and to tape for broadcast.

P2 Format
Apart from exporting from Adobe Premiere Pro or After Effects, Adobe Media Encoder can also be 
used independently to create virtual P2 cards from stand-alone media files.  For example, a card can 
be made from a single MXF video file by choosing “Add . . .” and then navigating to the Video folder 
of a P2 card and choosing the file.  As long as the P2 file structure in that card is intact, the associated 
audio files will be included, and a new P2 card can be made, containing only that video file.

Any video file can be transcoded to a P2 format using Media Encoder, simply by choosing “P2 
Movie” as the Format, and then choosing one of the options in the Preset drop-down.  The presets 
may also be edited, but straying from the existing presets may create a file incompatible with P2 
formats and equipment.

Web Content
A very common method of delivering HD content is via the World Wide Web.  The most common 
formats for delivery are Flash, QuickTime, Windows Media, and AVC/MP4.  Flash is also often used 
for delivering high-resolution video content on CD or DVD.  Web formats are created as data files 
and most formats are exported from Adobe Premiere Pro through Adobe Media Encoder.

Flash video
Standard .f4v and .flv files can be created from Adobe Premiere Pro via Adobe Media Encoder.   A 
project can also be sent via Dynamic Link to Encore, which can encode in .flv or .swf format for 
direct delivery to the Web as a Web version of a DVD or Blu-ray Disc project.

Other Formats
The other Web formats can be encoded from Adobe Premiere Pro or After Effects using Adobe 
Media Encoder.  The available common Web formats available include H.264, MPEG-4, Windows 
Media, and QuickTime.  Most formats have a wide variety of presets available, and each can be 
customized.  These options range from small frame all the way up to HD content.
 
Blu-ray Disc Authoring
Adobe Encore can be used to make a Blu-ray Disc image, or with a Blu-ray burner, burn a Blu-ray 
Disc.  An Adobe Premiere Pro or After Effects project can be sent by Dynamic Link to Adobe Encore, 
which can then author the project for Blu-ray Disc delivery.  A selection of Blu-ray format options is 
available.

HD Tape For Broadcast
As with archiving, printing to HD tape for broadcast will require the installation of a High Definition 
hardware card, such as those from AJA or Blackmagic Design, and a deck which records in the 
desired format.  To print to tape, choose File>Export to Tape, and then the appropriate deck option 
through the hardware card.

Written by David Jimerson, co-owner of Wrightsville Beach Studios, Ltd.  David Jimerson is a producer and 

the editor of series of instructional DVDs for Panasonic P2 cameras and P2 workflows, available at www.

hvxtraining.com. 


