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1. Product names 
Adobe® InDesign & InCopy CS5® and Citrix® XenApp Server 5.0. 

2. Document overview 
This document explains how an IT manager can reliably install and host Adobe InDesign & InCopy  CS5 on a Citrix 
XenApp Server 5.0 and have the applications published to a Macintosh,  Windows and/or Linux clients using the 
Citrix client software. This document assumes that you have  a basic understanding of the Windows Server/Client 
operating system, Citrix® XenApp Server software, and Adobe InDesign & InCopy CS5 installer software. 

A list of the Known Issues documented by Technical Support can be accessed by using the Citrix keyword via the 
Adobe Technical Support Knowledge Base.  

Here is the URL for the Citrix home page  http://www.citrix.com 

3. Product overview 
Adobe has validated the installation procedures and the remote application launching and  
running of Adobe InDesign & InCopy CS5 using Citrix XenApp Server 5.0.  
Important Note: We do recommend you refer to the Adobe InDesign and/or InCopy CS5 Installer  documenta-
tion in the User Guide.

3.1 System requirements 

You can find the system requirements for InDesign & InCopy CS5 products at the following  loca-
tions: 

3.1.1 InDesign CS5
http://www.adobe.com/products/indesign/systemreqs/
3.1.2 InCopy CS5 
http://www.adobe.com/products/incopy/systemreqs/ 

3.2 The environments used for validation were set up in the following ways: 

Host—An English Windows Server 2008 SP1 (Standard Edition) with Windows Terminal Server that is a  member of 
an Active Directory domain. 
Citrix—Citrix XenApp Server 5.0 

•  System Partition and Application partition moved from c: and d: to m: and o: respectively using  the Citrix 
driveremap.exe utility. 

•  Applications were deployed via the Citrix Web Interface. 
Important Note: Our validation environment did not include other Languages like Japanese or other  Citrix 
technologies like Metaframe Server, Presentation Server 4.0 or Program Neighborhood, etc. 

3.3 End-User Licensing Guidelines 

You must have a valid license to the desktop version to respective InDesign or InCopy software (“Soft-ware”) 
for all users who have access to the Software on a Citrix XenApp Server 5.0 terminal server-- not for the number 
concurrent users. All use is limited to users on your Internal Network, as defined  in the Software End User License 
Agreement. This section is intended to provide some clarity of the  terms of the EULA, but does not supercede 
the terms of the EULA. In the event of any conflict between  the terms of this User Document and the EULA, the 
terms of the EULA shall control.  
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4. Installing InDesign and InCopy  
4.1 Install InDesign CS5 or InCopy CS5 on a Citrix XenApp Server 5.0 Server: 

Important Note: If your Activated InDesign and InCopy CS5 licenses are not purchased through volume licensed 
program, then you must use non-Activating versions of InDesign and InCopy CS5 for  use in a Citrix environment. 
To learn more about Adobe’s volume licensing program, please contact an  Adobe reseller or Adobe sales repre-
sentative. 

These installations steps are based upon the specific environment indicated in the Environment section of this 
document.  

4.1.1 Running the application installers 

1) Choose a location to extract the Installer and hit Next. 
2) Double click the Installer setup file.
5) The installer will launch. 
6) Enter your serial number. 
7) Click Next 
8) Click Install 
9) Once the install is done, click Exit. 

4.1.2 Publish the Application(s) via Citrix 

1. Start the Citrix Access Management Console for XenApp Server 5.0 from Start > Programs > Citrix > Manage-
ment Consoles > Access Management Console.

Otherwise you can also launch the Access Management Console directly by double-clicking CmiLaunch.exe 
from C:\Program Files\Common Files\Citrix\Access Management Console - Framework. 

(Replace C: with the drive letter of your system drive if necessary) 

Important Note: Once you start the Management console, you’ll see a list of your farms on the  left hand side. If 
needed, type your user ID and password, to authenticate to the farm. 

2. Click + (plus) next to the farm to which you want to install the InDesign CS5 or InCopy CS5 applications. 

3. Right click the ‘Applications’ folder icon that is within the farm you just expanded and choose New > Publish 
application. The ‘Citrix Application Publishing Wizard’ will start. This wizard will guide you through the process of 
publishing an application. All of the following steps take place within the Citrix Application Publishing Wizard. 

4. A ‘Welcome’ screen is displayed. Select Next to continue the application publishing process.

5. Enter a Display Name for the application. If you’re not sure what to enter then use the name of the application 
(InDesign CS5 or InCopy CS5). The Application Description text field is optional. Click “Next”. 

6. The next screen lets you choose the type of application to publish. Select the ‘Application’ radio button (de-
fault). In the ‘Application Type’ select “Accessed from a server”. Leave the “Installed application” as the selection in 
the ‘Server application type’ drop down menu. Click on “Next”.

7. Click Browse under the Command Line text field. 

8. Navigate to where the InDesign CS5 or InCopy CS5 application is installed and select the InDesign. exe or 
InCopy.exe file. If you performed a standard install of InDesign this path will be C:\Program Files\ Adobe\Adobe 
InDesign CS5\InDesign.exe. (The standard install path for InCopy is the same, only with InCopy CS5\InCopy.exe 
at the end of the path.) Click “OK”. 

9. Leave the default values for the Working Directory text fields, and click Next. 

10.	 Add the servers on which the published application will run by clicking on “Add”. Select the servers and then 
click “OK”. Click “Next”.

11. Specify the Users who can use the published application. You can use any of the following scenarios: 
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—If there is a specific group that you wish to give usage privileges to, you can drill down through the domain tree 
and locate that group. To add the group, click Add and it will be listed in the box on the bottom of the window. 

—If you want to let anyone on your network use the application, select Allow Anonymous Connections.

12. Click “Next”.

13. The Application shortcut placement fields are optional. Select the check boxes to add application shortcuts 
to the client’s start menu, desktop and Programs folder (when accessing through Program Neighborhood). Click 
“Next”

14. You can configure advanced options like “Access Control”, “Content Redirection”, “Limits of instances of ap-
plication on server”, “Client options” and “Application appearance” options additionally. To configure these op-
tions check the “Configure advanced application settings” check box and click on “Next”. If you are unsure what 
settings to choose, leave everything at the default setting, and uncheck the check box for configuring advanced 
settings. 

15. If you do not wish to set advance options and keep them as default, click “Finish” to publish the application 
and make it available for network use via Citrix. 

16. If you need to install another application (InDesign CS5 or InCopy CS5) then return to step 2. Important Note: 
After you install InDesign or InCopy, the application installer may prompt you to re-start the server. If you receive 
this prompt, Adobe strongly recommends that you restart the system.

4. 2 Access InDesign & InCopy CS5 from a client compatible computer  

Important Note: These access instructions are specific to the environment as documented in section  3.2 

1. Start your Web browser and enter the URL specified by the IT Manager for Web Access to the Citrix  XenApp 
Server 5.0 Server 

2. Enter your specified Username & Password when the Citrix XenApp Server 5.0 Login main  window displays 
and then click Log-in. 

Note: IT Managers can set up the server to allow users to select the option, “Desktop Credential Passthrough” or 
they may require users to select the option, “Explicit User.”  

3. Double-click the icon to start InDesign or InCopy in the Citrix XenApp Server 5.0 Applications  window.  

Important Note: The IT Manager may grant application access rights on a user-by-user basis 

5. Basic acceptance tests for InDesign and InCopy 
5.1 After you complete the installation of InDesign or InCopy, test the application on a target com-
puter. This section details tests you can perform to ensure that you installed InDesign & InCopy CS5 
successfully. 

To verify that InDesign and InCopy plug-ins installed: 

1. Start InDesign or InCopy, and then verify that no error messages appear on the startup screen. 

2. Choose Help > Manage Extensions this will launch Adobe Extensions Manager CS5 

3. Under Products select InDesign CS5 / InCopy CS5. Verify that plug-ins are listed in the Scrollable Window.  

Important Note: You can also select plug-ins individually in the window, and then see the details under the 
Description or Advanced Tabs. 

5.2 Check that basic file actions and commands work correctly 

To check that basic file actions and command work correctly, do the following basic file actions and  commands 
on the target computer after you successfully start the applications and verify all plug-ins  are loaded and prop-
erly enabled: 

1. Choose File > New > Document and click OK with the application defaults 
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2. Choose File >Save As (InDesign) or File > Save Content As (InCopy) and choose a local or server  directory and 
name the file, and then click OK. 

3. Choose File > Open and navigate to a directory that contains either an existing InDesign document (INDD) or 
an existing InCopy document (ICML), select the document, and then click  Open. 

4. Make some modifications to the document, select File > Save a Copy (InDesign) or File > Save  Content Copy 
(InCopy), and then click OK. 

5. Perform InDesign specific acceptance testing: 

a. Choose File > Place and navigate to a directory containing file types that InDesign uses and  confirm that  	
	 you can place all of the following file types successfully: JPG, PSD, TIFF, EPS, AI, PDF, DOC, RTF, XLS, and XML. 

b. Confirm that you can edit the text files in both Layout and Story views 
c. Confirm that you can apply all transformations supported by InDesign to the Placed graphic  files in step 5. 
d. Confirm you can Print and Export a PDF file. 

6. Perform InCopy specific acceptance testing:

a. In a new InCopy document, choose Type > Fill with Placeholder Text. 
b. Switch to Story or Galley View and choose Changes > Track Changes in Current Story. 
c. Select the first paragraph and press Delete .  
d. Select a sentence in the second paragraph and choose Notes > Convert to Note. 
e. Choose Notes > Expand/Collapse Notes In Story. 
f. In the second paragraph, type a new sentence. 
g. Switch to Layout View. place a text insertion point in the beginning of the third paragraph,  
press F8 to display up the Notes palette, and then enter a note and press F8 again. 
h. Choose File > Save Content As, and then close the document. 
i. Choose File > Open, select the document saved in step h, and then verify that all edits were  
preserved.. 

6. Removing InDesign and InCopy 
6.1 Removal instructions 

6.1.1 Removing InDesign or InCopy from a Citrix Server consists of deleting the published appli-
ca-tion from the Citrix Management Console, then removing the application using the standard 
Add/ Remove Programs Control Panel. 

6.1.2 Delete the published application from the Citrix Management Console 
1. Start the Citrix Access Management Console for XenApp Server 5.0 from Start > Programs > Citrix > Manage-
ment Consoles > Access Management Console.

Otherwise you can also launch the Access Management Console directly by double-clicking CmiLaunch.exe 
from C:\Program Files\Common Files\Citrix\Access Management Console - Framework. 

(Replace C: with the drive letter of your system drive if necessary) 

Important Note: Once you start the Management console, you’ll see a list of your farms on the  left hand side. If 
needed, type your user ID and password, to authenticate to the farm.

2. Expand the farm object where the InDesign/InCopy application is installed. 

3. Click on the Applications folder to display your InDesign and InCopy applications should be shown  in the main 
pane of the window. 

4 Right click on InDesign CS5 or InCopy CS5, and choose Delete Published Application. 

5. Click Yes on the confirming dialog.  

6. Repeat step 4 if necessary to remove the other InDesign CS5 or InCopy CS5 application. 
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7. Close the “Management Console for XenApp Server 5.0” 

6.1.3 To remove the application using Add/Remove Programs 
1. Choose Start > Settings > Control Panel > Add/Remove Programs 

2. Select either InDesign CS5or InCopy CS5 by clicking on it’s name in the list of currently installed  programs. 

3. Click Change/Remove beside the application you want to remove to start the Adobe’s Installer,  then click Next. 

4. Select Remove, and then click Next. 

5. Click Uninstall  

6. Click Exit on the verification screen to leave the uninstaller. 

7. Repeat steps 2-6 to remove the other application. 

7. Troubleshooting 
Contacting Adobe Technical Support 

If you need to contact Adobe Technical Support, please prepare answers to the following questions so  that we 
can better assist you: 

1. Which Server Operating system and version number is the Citrix XenApp Server 5.0-based  server running? 
Which Service Pack (if any) has been applied to the server operating system? 

2. Which version of the Windows client operating system is the client computer? Which Service Pack  (if any) has 
been applied to the client operating system? Do these programs meet the environment  requirements listed in 
Environments section in this document? 

3. Which version of the Citrix XenApp Server 5.0 Server software are you currently running?  Which Citrix Hotfixes 
and Service Packs have you installed?  

4.  What is the problem statement (for example, “When I do X with Y, Z happens”)? If the problem  produces an 
error message, what is the exact wording of the message? 

5.  Which user profile is logged into the server (for example, Administrator or Power User)? Does the  problem 
occur when an Administrator profile is logged into the server? 

6.  Which user profile is logged into the client computer (for example, Administrator or Power User)?  Does the 
problem occur when an Administrator profile is logged into the client computer? 

7.  Can you reproduce the problem when you test the problem on the server? If so, what steps reproduce the 
problem? 

8.  What goal are you trying to achieve? Have you been able to achieve this goal in the past? If so,  did anything 
change recently in your environment that might be related to the problem? 

8. Known Issues  
As of June 2010, there are no known issues with installation procedures and the remote  application execution of 

Adobe InDesign CS5 and InCopy CS5 using Citrix XenApp Server 5.0

9. Support Statement for Windows Terminal Services  
Adobe InDesign and InCopy CS5 supports Windows Terminal Services and Citrix Server/ Client configurations.  
Citrix XenApp Server 5.0 Server implementations leverage core  Microsoft Windows Terminal Services. Adobe 
has performed limited testing with standard  Microsft Windows Terminal Services for Windows 2008 Server. Our 

testing coverage focused  on basic file actions consisting of the following: 

1. Remote Launching of the applications  

2. Creating and Saving new documents 
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3. Opening existing documents   
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