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How to add Flash movies and Flash video to a website
To add interest and interactivity, you can add movies created in Adobe Flash CS5 and Flash video to your site. Flash 
movies contain animated and interactive content, while Flash videos incorporate video from other sources, such as a 
video camera. For example, you might add an instructional Flash movie about model rocketry, or a slide show, or 
some video that documents a community event.


Adding Flash movies (SWF files)


You add a Flash movie just as you would an image, by browsing to and selecting the Flash file. Flash files have SWF 
as a file extension.


To add a SWF file:


1. Start Adobe Dreamweaver and open the document in 
which you want to insert the Flash movie.


2. Make sure the Common category in the Insert panel is 
selected.


3. Click the down arrow on the Media button and select 
SWF in the pop-up menu (Figure 1).


The Select SWF dialog box opens (Figure 2).


Figure 1 Media pop-up menu


Figure 2 Select SWF dialog box
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4. Locate and select the Flash movie (SWF), and then click 
OK (Windows) or Choose (Mac OS).


The Object Tag Accessibility Attributes dialog box opens 
(Figure 3).


5. In the Title text box, type a brief title to identify the 
movie’s contents. Then click OK.


A Flash content placeholder, rather than a scene from the 
Flash movie itself, appears in your document (Figure 4). 
This is because the page is pointing to the Flash SWF 
file. When a visitor opens this page, the browser plays the 
SWF file.


To determine how the movie plays when the page loads, 
you set options in the Property inspector.


6. Make sure the Flash content placeholder is selected.


7. In the Property inspector (Figure 5), select the Loop 
option to cause the movie to repeat as long as the visitor 
is on the page. Or, if you don’t want the movie to loop, 
make sure that the Loop option is not checked.


8. Select the Autoplay option to cause the movie to play 
when the page loads.


9. To test the movie, click Play.


Dreamweaver plays the Flash file in the document, 
showing you what visitors will see when they view the 
page in a browser.


10. When you are finished viewing the Flash movie, click 
Stop in the Property inspector.


Figure 3 Object Tag Accessibility Attributes 
dialog box


Figure 4 Flash content placeholder


Figure 5 Flash Property inspector
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Adding Flash video (FLV files)


Flash video plays like any other video content. When you add Flash video, Dreamweaver also inserts a set of 
playback controls. These controls appear in a browser when a visitor opens the page.


To add Flash video:


1. Click the down arrow on the Media button on the Insert 
panel and select FLV from the pop-up menu.


The Insert FLV dialog box opens (Figure 6).


2. Click the Browse button to the right of the URL text box.


3. Locate and select the Flash video (FLV), and then click 
OK (Windows) or Choose (Mac OS).


4. Make sure Progressive Download Video is selected in the 
Video Type menu at the top of the dialog box. 


The Progressive Download Video option enables visitors 
to see movies as they download instead of waiting until 
after the entire movie has downloaded.


Note: The Streaming Video option requires the use of 
Adobe® Flash® Media Server.


5. Click the Detect Size button to fill in the Width and 
Height boxes.


Dreamweaver requires this information to include the 
video.


6. Select a skin from the Skin pop-up menu.


This determines the appearance of the Flash video 
playback controls (Figure 7).


7. Select the Auto Play option to cause the video to play 
when the page loads.


8. Select the Auto Rewind option to cause the video to 
rewind automatically when it reaches the end.


9. Click OK to close the dialog box and insert the video.


A Flash Video placeholder appears in your document 
(Figure 8).


Note: If the Copy Dependent Files dialog box opens, 
click OK to copy the necessary scripts to your site for 
proper playback of the video.


10. Save the document. 


11. Select File > Preview In Browser and select a browser 
from the submenu to preview the page and test the video.


Figure 6 Insert FLV dialog box


Figure 7 Flash video in a browser with Clear Skin  
selected


Figure 8 Flash Video placeholder
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How to create Cascading Style Sheets
Cascading style sheets (CSS) are collections of formatting rules that control the appearance of content on a web page. 
By using style sheets, you can achieve greater consistency across your website (even if your site consists of only one 
page). CSS styles provide you with a wide range of options for formatting text. This guide shows you how to take 
advantage of Cascading Style Sheets to maintain consistency and to apply characteristics to text.


If you’ve been using Adobe Dreamweaver CS5, you may have been using CSS without knowing it. Dreamweaver 
formats all text with CSS by default. Every time you change certain text properties in the Property inspector, such as 
text size and text color, Dreamweaver prompts you to define a mew CSS rule or update a style for the text. 
Dreamweaver places these style definitions in the beginning of each web page’s code. A collection of these 
definitions is known as an internal style sheet, because it is contained within an individual web page.


Internal style sheets (sometimes called embedded style sheets) are great for maintaining consistency within a 
document, but Cascading Style Sheets are especially useful for maintaining consistency across a number of different 
pages. By using an external style sheet—a separate document that holds CSS style information—you can make sure 
that text appearance is consistent across multiple pages. Not only does a consistent appearance look more 
professional, but usability experts say that site visitors find what they’re looking for more easily on sites where text 
appearance and placement is consistent.


Defining CSS styles


The most basic way to define CSS styles in Dreamweaver is to apply formatting by using the CSS options in the 
Property inspector. When you do, you are prompted to create a new CSS rule. You need to name the new rule and 
define the type of CSS.


There are three main types of CSS:


A Class style is similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a Class style with these attributes and 
then apply this style to all body text in your web site. 


A Tag style applies global formatting to individual HTML tags, as opposed to individual selections. Suppose you 
want to modify the Heading 1 paragraph style to always appear in purple text. Instead of creating a class style and 
applying it to every heading in the document, you can create an HTML Tag style with these attributes and apply it to 
the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


An ID style is only used once within a document or page. It is used as a unique identifier (ID) for a style applied to 
elements such as a header, banner, or menu that is only present in one location in the document.


A Compound style is used to format text in different ways based on how a user interacts with the text. For example 
you can use a compound style to change the look of text when a user rolls over a link. Compound styles can also be 
used to group selectors, for tags or classes that share the same properties.


Whenever possible, redefine existing tags instead of creating new CSS styles. The existing tags provide a useful 
hierarchy for both you and the users of your site, and they also make it easier for people using screen readers to use 
your site.


In addition to using the CSS options in the Property inspector, you can define, apply, and modify CSS styles by using 
the CSS panel, which you will do in this guide.
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To redefine an existing HTML style tag by using a CSS Tag rule:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document.


5. Select the text.


6. Using the Property inspector, apply an HTML tag such as 
Heading 1 to the text.


The text appears in the default Heading 1 format 
(Figure 1). 


7. Make sure the CSS Styles panel is open and expanded.


If it is not open, select Window > CSS Styles. 


8. To create a new style, click the New CSS Rule button (+) 
at the bottom of the CSS Styles panel (Figure 2).


The New CSS Rule dialog box opens (Figure 3).


9. In the Selector Type pop-up menu, select Tag. 


This option lets you add CSS properties to an existing 
HTML tag.


10. From the Selector Name pop-up menu, select h1 (the tag 
for Heading 1).


11. In the Rule Definition pop-up menu, select This 
Document Only or New Style Sheet File. 


The option This Document Only defines the style as part 
of the document’s internal style sheet. The option New 
Style Sheet File defines the style as part of an external 
style sheet.


12. Click OK.


Note: If you choose to create an external style sheet by 
selecting New Style Sheet File, you are prompted to 
select a location for the new style sheet (.css) document.


Figure 1 Text with default Heading 1 tag applied


Figure 2 CSS Styles panel


Figure 3 New CSS Rule dialog box


New CSS Rule 
button
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The CSS Rule Definition dialog box opens with the Type 
category selected (Figure 4). The dialog box includes the 
following categories: (For more details, select Help > 
Dreamweaver Help.)


• Type changes text properties such as font, size, and 
color.


• Background controls background properties. For 
example, you can use a colored background or an 
image or create a fixed or scrolling background.


• Block controls spacing and alignment of text and 
lines on the document.


• Box changes the box that surrounds a block element. 
It affects properties such as height, width, padding, 
and margins.


• Border changes the border properties around text, 
such as style, width, and color.


• List controls list properties such as text type and 
bullet appearance.


• Positioning defines text position on the page.


• Extensions controls page breaks and the visual 
appearance of the cursor.


13. Select options for Type, such as the following (Figure 5):


• Select Verdana, Geneva, Sans-serif from the Font-
Family pop-up menu.


• Select 14 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit (in the 
pop-up menu to the immediate right of the Font-size 
pop-up menu).


• Type #006600 in the Color box, or select a color in 
the Color Picker.


Note: All Heading styles are bold by default. If you don’t 
want the text to be boldface, select Normal from the 
Weight pop-up menu.


14. Click Apply. 


Observe that the Heading 1 text, or the text you chose, in 
the document has changed. (You may need to move the 
dialog box.)


15. To change the background, select Background in the 
Category pane on the left.


The Background category of the CSS Rule Definition 
dialog box opens (Figure 6).


16. Select a color in the Color Picker or type a hexadecimal 
number in the Background-Color text box such as 
#CCCCCC. (Make sure the background color is lighter 
than the color of the text.)


Figure 4 CSS Rule Definition dialog box 


Figure 5 CSS Rule Definition dialog box showing 
type options


Figure 6 CSS Rule Definition dialog box showing 
background options
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17. Click Apply to see your changes.


18. To change the border and its properties, select Border in 
the Category pane.


The Border category of the CSS Rule Definition dialog 
box opens (Figure 7).


19. Under Style, you can make changes such as deselecting 
the option Same For All and selecting the option Solid in 
the Top pop-up menu.


20. Under Width, you can make changes such as typing 1 in 
the Top pop-up menu, and leaving pixels selected as the 
measurement unit.


21. Under Color, you can make changes such as entering 
#006600, or whatever color you chose in step 13.


22. Click OK.


The CSS Rule Definition dialog box closes.


Observe that the appearance of the Heading 1 text you 
created has now changed (Figure 8). 


23. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


24. Make sure that All is selected in the CSS Styles panel.


Observe that the h1 style now appears under <style> in 
the All Rules pane, indicating that this tag is part of the 
style sheet. (If the h1 style is not visible, click the plus 
sign (Windows) or the disclosure triangle (Mac OS) to 
the left of <style>.) Also observe that properties for this 
tag appear in the Properties pane (Figure 9).


25. To make further changes to the tag style, select it and 
click the Edit Rule button. 


The CSS Rule Definition dialog box opens. Make any 
changes you wish. When you are finished, click OK.


Note: You can also make changes using the Properties 
area of the CSS Styles panel, but it is easier to make 
changes using the CSS Rule Definition dialog box.


26. To apply the style to new text, select the text and then 
select Heading 1, or the tag you modified, in the Text 
Property inspector.


Figure 7 CSS Rule Definition dialog box showing 
options for formatting borders


Figure 8 Text with new style formatting applied 


Figure 9 Style added to CSS Styles panel


Edit Rule button


Properties of 
selected rule


CSS Tag rule
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To disable or enable rule properties:


You can disable individual rule properties for testing or to 
fine-tune appearances.


1. Select the rule in the Properties pane of the CSS Styles 
panel.


2. Click the Disable/Enable CSS Properties button.


A red circle appears next to the property (Figure 10) and 
the text to which the rule applies is changed (Figure 11).


To enable the property, do one of the following:


• Double-click the property.


• Select the rule and click the Disable/Enable CSS 
Properties button.


Note: As an alternative to clicking the Disable/Enable 
CSS Properties button, you can disable or enable a rule 
by clicking the space to the left of the rule.


Figure 10 Disabling a rule property


Figure 11 Result of disabling property


Disable/Enable CSS 


Property button
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To create a new CSS Class rule:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document. Make sure that no 
formatting is applied to the text (Figure 12).


5. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel.


The New CSS Rule dialog box opens (Figure 13).


7. In the Selector Type pop-up menu, select Class. 


This option creates a new Class rule.


8. In the Selector Name box, type a name for the style such 
as .warning.


Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver will add this 
automatically.


9. In the Rule Definition pop-up menu, select This 
Document Only or New Style Sheet File. 


The option This Document Only defines the style as part 
of the document’s internal style sheet. The option New 
Style Sheet File defines the style as part of an external 
style sheet.


Note: If you choose to create an external style sheet by 
selecting New Style Sheet File, you are prompted to 
select a location for the new style sheet (.css) document.


10. Click OK.


The CSS Rule Definition dialog box opens (Figure 14).


11. Select the options for Type, such as the following 
(Figure 14): 


• Select Arial, Helvetica, Sans-serif in the Font-
Family pop-up menu


• Select 12 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit.


• Type #CC0033 in the Color text box, or select a 
color in the Color Picker.


Figure 12 Text with no formatting applied


Figure 13 New CSS Rule dialog box


Figure 14 CSS Rule Definition dialog box 
showing type options 
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12. To change the formatting of text blocks, select Block in 
the Category pane.


The Block category of the CSS Rule Definition dialog 
box opens (Figure 15).


13. In the Letter-Spacing box, you can make changes such as 
typing 3 and selecting pixels for the measurement unit.


This setting adds space between each letter. 


14. In the Text-Indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit.


15. Click OK.


The CSS Rule Definition dialog box closes.


16. Select the document text.


17. Make sure the Property inspector is open and the HTML 
option is selected.


The Property inspector is docked at the bottom of the 
screen. If the Property inspector is not open, select 
Window > Properties.


18. Select warning, or the name of your style, from the Class 
pop-up menu (Figure 16).


19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once.


Observe that the format of the text has changed 
(Figure 17).


20. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


21. Make sure that All is selected in the CSS Styles panel.


Observe that the newly created CSS rule now appears 
under <style> in the All Rules pane, indicating the new 
rule is part of a CSS style sheet. Also observe that 
properties for the style appear in the Properties pane.


22. To make further changes to the style, select it and click 
the Edit Rule button. 


The CSS Rule Definition dialog box opens.


Note: You can also make changes by using the Properties 
pane of the CSS Styles panel.


Figure 15 CSS Rule Definition dialog box 
showing options for formatting text blocks


Figure 16 Text Property inspector


Figure 17 Formatting applied to text
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Grouping selectors


Often, you will want multiple tags to share characteristics. For example, you might want all headers on your site--
those tagged by h1, h2, h3, and h4--to use the Verdana, Geneva, sans-serif font family, be colored maroon, and have a 
one-point border above them. In such cases, you can group selectors by using the Compound Selector option in the 
CSS Styles panel.


To group selectors:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document. Make sure that no 
formatting is applied to the text (Figure 12).


5. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel.


The New CSS Rule dialog box opens (Figure 13).


7. In the Selector Type pop-up menu, select Compound. 


Compound rules affect two or more tags.


8. In the Selector Name box, enter the tags to be included in 
the group, separated by commas, such as h1, h2, h3, h4 
(Figure 18).


9. In the Rule Definition pop-up menu, select a location for 
the rule.


10. Click OK.


The CSS Rule Definition dialog box opens.


11. Enter properties for the group, such as font family, 
background color, and border.


12. Click OK.


The CSS Rule Definition dialog box closes, and the 
group selector is listed in the CSS Styles panel. The 
properties you entered will now apply to all tags included 
in the group.


13. Select the text you typed in step 4. 


14. In the Text Property inspector, select one of the four 
grouped tags from the Format pop-up menu.


Figure 18 Entering a group selector


Figure 19 Group selector in CSS Styles panel
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Using descendant selectors


Descendant selectors let you specify a tag or class that appears within (as a descendant of) another tag or class. For 
example, since headings are generally bold, text that you want to emphasize within a heading might not show up if 
you simply use a <strong> tag, which is the default when you apply Bold in the Text Property inspector. You can use 
a descendant selector to apply an alternative form of emphasis, such as changing the color of text every time you have 
a <strong> tag that appears within an <h2> tag. 


To create a descendant selector:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document. Make sure that no 
formatting is applied to the text (Figure 12).


5. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel.


The New CSS Rule dialog box opens (Figure 13).


7. In the Selector Type pop-up menu, select Compound. 


Compound rules affect two or more tags.


8. In the Selector Name box, enter the tag that is to be a 
descendant of another tag, such as h2 strong.


The Selector Definition box states how the rule applies, 
such as “This selector name will apply your rule to all 
<strong> elements that are within any <h2> elements.” 
(Figure 20).


9. In the Rule Definition pop-up menu, select a location for 
the rule.


10. Click OK.


The CSS Rule Definition dialog box opens.


11. Select a text color that differs from the text color defined 
for <h2>.


12. Click OK.


The CSS Rule Definition dialog box closes, and the 
descendant selector is listed in the CSS Styles dialog box. 
The properties you entered will now apply to all tags that 
are descendants of the first tag. In the H2 tag example 
(Figure 21), the <h2> tag applies to all the text, but the 
part of the text to which the <strong> tag is applied has a 
different color.


Figure 20 Defining a descendant selector


Figure 21 Result of descendant selector applied


<h2> tag <strong> tag applied
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13. Select the text you typed in step 4. 


14. In the Text Property inspector, select h2 from the Format 
pop-up menu.


15. Select a word from the text to which you applied the 
<h1> tag.


16. In the Text Property inspector, click the Bold button to 
apply the <strong> tag to the word.


Using pseudo class selectors


Pseudo class selectors are special selectors which refer to characteristics of the page instead of some element of a 
class or tag itself. 


Pseudo class selectors are especially useful for links (Figure 22). By default, pseudo class selectors apply to all links 
in a page. The following pseudo class selectors are available in Dreamweaver:


• Link (a:link) controls the normal state of the link. The default color is blue.


• Visited (a:visited) controls the link format after a visitor has clicked it. The default color is purple.


• Hover (a:hover) controls the link format as the pointer moves over the link. The default color is red.


• Active (a:active) controls the link format while it is being clicked. The default color is red.


Figure 22 Pseudo class selectors


To add a pseudo class selector:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


5. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel.


The New CSS Rule dialog box opens.


6. In the Selector Type pop-up menu, select Compound. 


Compound rules affect two or more tags.


Visited link


Unvisited link


Link with pointer hovering over it
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7. In the Selector Name box (Figure 23), select one of the 
following from the popup menu:


• a:link


• a:visited 


• a:hover 


• a:active


For this example, select a:link.


8. Click OK.


The CSS Rule Definition dialog box opens.


9. Select a type color or other properties.


10. Click OK.


The CSS Rule Definition dialog box closes, and the 
pseudo class selector is listed in the CSS Styles dialog 
box. The properties you entered will now apply to all 
links in the page.


11. Create a link and preview the page in a browser.


Figure 23 Selector Name box in the New CSS 
Rule dialog box
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Edit styles


After you create styles, you can still make changes to them by using the Edit Rule button.


To edit styles:


1. To view a style sheet’s rules, click the plus symbol 
(Windows) or triangle (Mac OS) beside the style sheet 
you want to edit in the CSS Styles panel.


Dreamweaver displays style sheet’s rules. 


2. Select the rule you want to edit.


3. At the bottom of the CSS Styles panel, click the Edit Rule 
button (Figure 24).


The CSS Rule Definition dialog box for the selected style 
opens (Figure 25).


4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK.


The changes take effect immediately. Because you are 
editing an external style sheet, the same changes are 
applied to any other documents attached to this style 
sheet.


Figure 24 CSS Styles panel


Figure 25 CSS Rule Definition dialog box


Edit Rule 
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How to work with external Cascading Style Sheets
Many web professionals find it that using an external style sheet--a style sheet that exists in its own file--offers a 
number of advantages over including styles in the header of an HTML file. These advantages include:


• Flexibility: With CSS stored in one file, you can easily change the appearance of all documents that refer to the 
external style sheet.


• Consistency: All documents sharing the same style sheet will have a similar appearance.


Using an external style sheet separates form from content. Separating form from content is a widely-adopted principle 
in web design which allows, among other benefits, for content to be shared in a range of contexts. 


Exporting CSS rules to an external style sheet


You can convert an internal CSS style sheet to an external one by exporting it, removing the internal CSS style sheet, 
and attaching the exported CSS style sheet to one or more web pages. 


To export a style sheet:


1. Make sure the CSS Styles panel is open (Figure 1).


If it is not, select Window > CSS Styles. 


2. Make sure that All is selected in the CSS Styles panel.


3. Select the CSS rule you want to move to an external style 
sheet.


Note: To move more than one rule at a time, you can 
Shift-click to select multiple rules that are next to each 
other. To select multiple rules that aren’t next to each 
other, you can Control-click (Windows) or Command-
click (Mac OS) the names of the rules.


4. Right-click (Windows) or Control-click (Mac OS) the 
selected rule(s) and select Move CSS Rules in the context 
menu.


The Move To External Style Sheet dialog box opens 
(Figure 2).


Figure 1 CSS Styles panel


Figure 2 Move To External Style Sheet dialog box
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5. Select A New Style Sheet and then click OK.


The Save Style Sheet File As dialog box opens 
(Figure 3).


6. Browse to a location for the CSS file, enter a name for the 
file, and click Save.


Note: It is good practice to place CSS files in their own 
folder and good practice to name that folder css.


Dreamweaver exports the CSS file.


Figure 3 Save Style Sheet File As dialog box


To delete an internal style sheet:


1. In the CSS Styles panel under All, select <style>.


2. Click the Delete Embedded Stylesheet button (Figure 4).


Dreamweaver removes the internal style sheet. If the 
internal style sheet contains any styles still being used on 
the page, the affected text reverts to its default 
formatting, or it takes on the formatting defined in the 
external style sheet.


Figure 4 CSS Styles panel


Delete Embedded Style 
Sheet button
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Attaching an external style sheet


Once you create an external style sheet and attach it to multiple documents, you can instantly change any style in all 
your documents by making changes to the external style sheet.


Note: Once you start using an external style sheet, it is best to make all text formatting changes through that style 
sheet. If you make formatting changes through the Property inspector, Dreamweaver will automatically create a new 
internal style sheet.


To attach an external style sheet:


1. Open a document.


1. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


2. Click the Attach Style Sheet button (Figure 5).


The Attach External Style Sheet dialog box opens 
(Figure 6).


3. Click Browse, navigate to your saved style sheet, select 
it, and click OK (Windows) or Choose (Mac OS) 
(Figure 7).


Figure 5 CSS Styles panel


Figure 6 Attach External Style Sheet dialog box


Figure 7 Selecting a CSS style sheet to attach


Attach Style 
Sheet
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4. In the Attach External Style Sheet dialog box, click OK 
(Figure 8).


Dreamweaver attaches the style sheet to your document 
(Figure 9).


The style sheet’s rules are now available in the Property 
inspector. You may need to expand the style sheet to see 
its rules.


You can attach the same style sheet to multiple 
documents. When you make changes to the style sheet, 
those changes will appear in all documents the style sheet 
is attached to.


Figure 8 Confirming style attachment


Figure 9 Attached style sheet
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Creating external style sheets


You can also create external style sheets directly. 


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Make sure the CSS Styles panel is open (Figure 10).


If it is not, select Window > CSS Styles.


5. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel.


The New CSS Rule dialog box opens.


6. Select one of the following types of styles:


• Class (Can Apply To Any HTML element). Make 
your own HTML tag by naming a new style and 
defining its formatting.


◦ In the Selector Type pop-up menu, select Class.


◦ Type a name in the Selector Name box.


Note: Class names typically begin with a period 
and do not have spaces or special characters. 
Example: .highlight (Figure 11).


• Tag (Redefines an HTML Element). Change the 
default format of any tag in a document.


◦ In the Selector Type pop-up menu, select Tag.


◦ In the Selector Name pop-up menu, select the 
type of tag to redefine (for example, H1 tag, 
Body, or Table) (Figure 12).


• ID (Applies To Only One HTML Element). 


◦ In the Selector Type pop-up menu, select ID.


◦ Type a name in the Selector Name box.


• Compound (Based On Your Selection).


◦ In the Selector Type pop-up menu, select 
Compound. 


◦ Compound selectors include descendant, group, 
and pseudo class selectors. Each are discussed 
in detail earlier in this guide.


Figure 10 CSS Styles panel


Figure 11 Create your own HTML tag (class)


Figure 12 Modify an existing tag
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7. In the Rule Definition pop-up menu, select New Style 
Sheet File.


8. Click OK.


The Save Style Sheet File As dialog box opens 
(Figure 13).


9. Name and save the style sheet in a folder named css in 
your local root folder.


10. Make sure Site Root is selected in the Relative To box.


11. Click Save.


12. Use the CSS Rule Definition dialog box to set the 
formats for the new style.


13. Click OK.


The new external style sheet is automatically attached to 
the current document and listed in the CSS Styles panel 
(Figure 14).


Figure 13 Save Style Sheet File As dialog box


Figure 14 New external style sheet


Style sheet
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How to create forms
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide feedback, 
sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS5, you can create a 
variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and clickable 
images (such as a Submit button).


The Forms category in the Insert panel (Figure 1) contains buttons for creating forms and inserting form elements.


Figure 1 Forms category in the Insert panel


The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form.
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Setting up a form


You set up a form by inserting it and configuring options through the Property inspector.


To set up a form:


1. Open a page in Dreamweaver.


2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page. 


Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert panel, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create.


3. Select the Forms category in the Insert panel (Figure 1), 
and click Form. 


A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may need 
to click outside the div to see the entire form outline.


Form options appear in the Property inspector.


4. From the Method pop-up menu in the Property inspector 
(Figure 3), select either GET or POST.


• GET appends the form contents to the URL specified 
in the Action text box. Use GET if the form data is 
short and the results of the form will lead to a page 
that you want the visitor to be able to bookmark.


• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for instance, 
the form includes a text field that the visitor can use 
to type an unlimited amount of text). 


5. In the Action text box, type the URL or CGI script that 
will process the form.


Note: Get this information from your site administrator.


Figure 2 Blank form


Figure 3 Method menu in the Property 
inspector
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Adding form elements


Using the Forms category in the Insert panel, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose.


Using form fields


Form fields enable site visitors to enter text into a form. Form fields include the following:


• Text fields, in which a visitor types a response


• File fields, in which a visitor types the path of a file to upload to your server


Adding text fields


Text fields provide a space in which visitors can enter text.


To add a text field:


1. Click the Text Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens 
(Figure 4).


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the text field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors.


3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


The label will be displayed next to the text field, 
indicating to the visitor what to put in the field.


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


5. In the Add Form Tag dialog box, click Yes.


The text field appears in the form (Figure 5).


6. Click in the text field (not the label) to select it.


7. In the form Property inspector (Figure 6), select one of 
the three types of text fields:


• Single Line text for short answers


• Multi Line text for long answers such as the visitor’s 
description of a problem with a purchased item


• Password text for passwords (in which asterisks 
appear in place of typed characters)


Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert panel.


Figure 4 Input Tag Accessibility Attributes dialog 
box


Figure 5 Example of text field in the form


Figure 6 Form Text Field Property inspector
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Adding a file field


A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file.


To add a file field:


1. Click the File Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the file field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The file field appears in your document (Figure 7).


5. Click in the file field (not the label) to select it. In the 
Property inspector, in the Char Width text box, specify 
the maximum number of characters visitors will see in 
the field (Figure 8).


6. In the Max Char text box, specify the maximum number 
of characters the field will hold.


Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field.            


Figure 7 Example of file field


Figure 8 Form File Field Property inspector
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Using checkboxes and radio buttons


Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on or 
off, or they can select one or more options from a group of options. With radio buttons, visitors can select only one 
option from a group of options.


To add a checkbox:


1. Click the Checkbox button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the checkbox in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The checkbox button appears in your document 
(Figure 9).


5. Click the checkbox (not the label) to select it.


6. In the Checked Value text box in the Property inspector 
(Figure 10), enter a value for the checkbox.


This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes.


7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked.


Figure 9 Example of checkbox


Figure 10 Form Checkbox Property inspector
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To add a group of radio buttons:


1. Click the Radio Group button in the Insert panel to insert 
a group.


The Radio Group dialog box opens (Figure 11).


2. Enter a name in the Name text box.


3. Click the plus (+) button to add a radio button to the 
group.


4. Enter a label and (if you want) a checked value for each 
button.


5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons.


6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table. 


7. Click OK.


The group of radio buttons is added to the form 
(Figure 12).


8. Click a radio button (not its label) to select it.


9. In the Property inspector, click Checked or Unchecked to 
indicate if this option is selected by default (Figure 13).


Figure 11 Radio Group dialog box


Figure 12 Example of Radio Group


Figure 13 Form Radio Button Property inspector







Adobe Dreamweaver CS5 Activity 3.7 guide


© 2010 Adobe Systems Incorporated How to create forms 7


Using list menus and drop-down menus (List/Menu)


Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item from 
a pop-up menu.


To add a list menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the list menu in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore ( _ ).


3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 14).


5. Click the list/menu field (not its label) to select it.


6. In the Property inspector, for Type, select List 
(Figure 15).


7. In the Height text box, enter the number of items the list 
will display.


If this number is less than the total number of items in the 
list, a scroll bar will be displayed.


8. If you want to allow visitors to select more than one item 
in the list, select Allow Multiple for Selections.


9. Click the List Values button to add the list items.


The List Values dialog box opens (Figure 16).


10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list.


11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


If you enter no value, then the form sends the label as the 
value for that item.


12. Press Enter (Windows) or Return (Mac OS).


13. To add another item to the list, click the plus (+) button.


14. When you finish, click OK to close the List Values dialog 
box.


15. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Property inspector (Figure 17).


Figure 14 Example of list/menu field


Figure 15 Form List Menu Property inspector


Figure 16 List Values dialog box 


Figure 17 Choose which item is initially selected
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The Initially selected item appears in the form 
(Figure 18).


Figure 18 Form list with three items in the list


To add a drop-down menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the pop-up menu in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 19).


5. Click the list/menu field (not its label) to select it. 


6. In the Property inspector, for Type, select Menu.


7. Click the List Values button to add the menu items.


The List Values dialog box opens (Figure 20).


8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu.


9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


10. Press Enter (Windows) or Return (Mac OS).


11. To add another item to the menu, click the plus (+) 
button.


12. When you finish, click OK to close the List Values dialog 
box.


13. To have one of the items in the menu selected by default, 
select that item in the Initially Selected text box in the 
Property inspector. 


Note: To see the menu items in operation,  preview this 
page in a browser (Figure 21).


Figure 19 A list/menu field


Figure 20 List Values dialog box


Figure 21 Preview in a browser
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Using form buttons


Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser's default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice.


To add a standard text button:


1. Click the Button button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.


3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box.


Note:  A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the button’s 
value attribute, which you will set in the next step.


A text button appears in the document (Figure 22).


Note: In this example, a Submit button is placed below 
an existing file field.


4. Click the button to select it.


5. In the Property inspector’s Value text box, enter the text 
you want to appear on the button (Figure 23).


Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands (for 
example, “Send Message” or “Update Profile” or 
“Register”).


6. Select the type of Action (usually this is Submit Form).


Figure 22 Example of text button


Figure 23 Form Button Property inspector
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Adding a graphical submit button


You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel.


To add a graphical submit button:


1. Click the Image Field button in the Insert panel.


The Select Image Source dialog box appears (Figure 24).


2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Choose (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


3. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.


4. Don’t enter a label for the button. Click the OK button to 
close the Input Tag Accessibility Attributes dialog box.


The graphical submit button appears in your document 
(Figure 25).


5. Click the button to select it.


6. In the Alt text box, type alternate text you want to appear 
in place of the image for text-only browsers (Figure 26). 
This should match any text displayed on the button.


Note: You can also click the folder icon beside the Src 
text box to select a new image for the button.


Figure 24 Select Image Source dialog box


Figure 25 Example of graphical submit button 


Figure 26 Form Image Field Property inspector
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Using jump menus for navigation


A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements.


To add a jump menu:


1. Click the Jump Menu button in the Insert panel.


The Insert Jump Menu dialog box opens (Figure 27).


2. Complete the dialog box.


For more information, click the Help button in the dialog 
box.


3. Click OK.


Figure 27 Insert Jump Menu dialog box
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How to use templates
You can use an Adobe Dreamweaver CS5 template to create multiple pages with the same layout. In a template, you 
control which page elements should remain constant in documents based on that template and which elements can be 
changed from page to page. Templates are helpful for building a website in which most pages have the same header, 
navigation system, and other elements. Using templates helps you save time as well as create and maintain a 
consistent look when more than one person is developing a site.


Creating a template


You create templates from existing pages, setting editable regions on these pages that will hold content on each page 
created from the template.


To create a template:


1. Start Dreamweaver.


2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as div 
tags (Figure 1).


Note: You may want to create navigation elements in 
Adobe Fireworks CS5 and export them as HTML 
documents.


3. Select File > Save As Template.


4. In the Save As Template dialog box (Figure 2), give the 
template a name. You can also enter a brief description of 
the template. Then click Save. If Dreamweaver asks if 
you want to update links, click Yes.


Dreamweaver creates a Templates folder in your site root 
folder and saves your template in that folder. Template 
files have a .dwt file extension.


Figure 1 Common elements on a web page


Figure 2 Save As Template dialog box
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To create an editable region:


1. In the Layout category of the Insert panel, click Draw AP 
Div, and then drag on the page to create a new div to 
represent the editable region in the template.


Note: You also click to indicate where to place the 
editable region, but using a div gives you more control 
over page layout. 


2. With the div still selected, do one of the following to 
create an editable region:


• Select Insert > Template Objects > Editable Region.


• Right-click (Windows) or Control-click (Mac OS) 
the region and select Templates > New Editable 
Region from the context menu.


• In the Common category of the Insert panel, click the 
Templates button (Figure 3), and select Editable 
Region from the pop-up menu.


The New Editable Region dialog box opens (Figure 4).


3. In the dialog box, enter a unique name for the region, and 
click OK.


The editable region is within the selected div, and is 
enclosed in a light blue rectangle on the template 
(Figure 5).


Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name.


4. Save and close the template.


Figure 3 Templates button on the Insert panel


Figure 4 New Editable Region dialog box


Figure 5 New editable region inside the div


Templates
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To create a document based on a template:


Once you create a template, you can use it to create new 
documents.


1. Select File > New.


2. Save the new page and give it a name, such as 
index.html.


3. In the New Document dialog box, select the Page From 
Template category.


The dialog box displays your sites and all of the 
templates for the selected site (Figure 6).


4. In the Sites list, select the site that contains the template 
you want to use.


5. Select the template you want to use.


6. Make sure the Update Page When Template Changes 
option is selected.


With this option selected, Dreamweaver can update all 
template-based pages if you change the template later.


7. Click Create to create a new template-based page.


The document opens in the Document window.


8. Click in one of the editable regions, and add text.


9. Move the pointer over a page area that is not editable, and 
observe that you cannot make changes.


10. Save the page.


Figure 6 Page From Template category in the New 
Document dialog box
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Editing a template


You can edit a template at any time, even if you have created pages based on the template.


To edit a template:


1. Select Window > Assets.


The Assets panel opens.


2. Click the Templates button on the left side of the panel 
(Figure 7).


A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to see 
this.)


3. Select the template you wish to edit and do one of the 
following:


• Double-click the name of the template.


• Click the Edit button at the bottom of the panel 
(Figure 7).


4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired.


5. Save the edited template by choosing File > Save.


The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 8).


Figure 7 Assets panel


Figure 8 Update Template Files dialog box


6. Click Update to update the documents based 
on the changes you made in your template.


If you have enabled check in/check out, and 
the files to be updated are currently checked 
in, Dreamweaver asks to check these out 
before it can update them.


If you have changed or deleted editable 
regions, Dreamweaver may warn you that 
editable region names are inconsistent with 
files that have been created based on the 
template.


To resolve this problem, take the following 
steps:


a. In the Inconsisten Region Names dialog 
box (Figure 9), select a region from the 
list.


b. In the Move Content To New Region 
menu, select a new region in which you 
want to place the content from the 
selected region .


Templates


Edit
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c. Repeat these steps  for the remaining regions in the 
list.


7. Click OK.


The Update Pages dialog box displays a summary of the 
updates performed (Figure 10). You may need to select 
Show log to view the Status information.


8. Click Close.


Figure 9 Inconsistent Region Names dialog box 
with Move Content To New Region menu


Figure 10 Update Pages dialog box


Deleting a template


To delete a template:


1. Select the template in the Assets panel.


2. Click the Delete button (trash can icon) at the bottom of the panel and confirm that you want to delete the 
template.


The template file is deleted from your site.


Documents that were based on a template you have deleted retain the structure and editable regions the template 
file had before you deleted it. To turn such a document into a normal HTML file without editable or locked 
regions, you must detach it from the template.
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Detaching from a template


To remove the template structure and constraints from a document based on a template, you can detach the document 
from the template. When a document is detached from its template, you can edit any element, including the regions 
that were previously locked.


To detach a file from a template


1. To detach a document from a template, open the document.


2. Select Modify > Templates > Detach From Template.
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How to make websites accessible
Increasingly, government, corporate, and non-profit standards call for making websites accessible--making them 
readable for users with disabilities. These users may have screen readers and other interpretive devices. To make your 
site accessible, consider the following techniques.


Alternate text


Alternate text for images is critical for many devices that assist disabled people to access the web. The Property 
inspector in Adobe Dreamweaver CS5 has an Alt text box for entering alternative text for an image, link, or button. 
The text can be descriptive and as long as necessary, but it should be as succinct as possible.


Cascading Style Sheets (CSS)


Developers use CSS to separate content from presentation of their websites, allowing assisting devices easier access 
to the information provided in the content. Developers also use CSS to create a consistent structure for text content, 
aiding interpretive devices (such as text-to-speech browsers).


Image maps


Provide alternate text for hot spots in images to make them readable by interpretive devices.


Tables


Provide alternate text descriptions for tables, such as identifiers of row and column headings for data tables or longer 
descriptions for tables with textural information.
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Templates and library objects


Designers can create a single, accessible template or a small set of templates as the basis of the entire site. Templates 
limit mistakes when multiple designers are working on a site. In addition, templates foster a consistent, easy-to-use 
site that keeps visitors oriented and has consistent common elements such as navigation bars.


Frames


Add descriptions of frames in the Adobe Dreamweaver CS5 Property inspector. This alternative text provides 
additional information to web browsers and readers as visitors navigate each frame.


Movies


Use the Accessibility panel in Adobe Flash Professional CS5 to provide text equivalents where appropriate. If there 
are movie elements that are purely decorative, are repetitive, or otherwise convey no content, then make those 
elements inaccessible by deselecting the option, “Make Object Accessible.” Use the Description section of the panel 
to provide context for the entire movie.


Device independence


Device independence means that your web page should not require a particular hardware device in order to use it. For 
instance, the page should not require that the user have a mouse in order to use it—all controls should be manageable 
from the keyboard. Provide a keyboard equivalent for each button, and include all links and buttons in the tab index, 
so that visitors can use the Tab key to move from one element to the next. 


Use the Behaviors panel in Dreamweaver to create rollovers and other scripts that are triggered by logical events, 
such as onFocus and onBlur. Create scripts that combine mouse events with logical events to support a variety of 
visitors. For more about behaviors, see “Adding JavaScript behaviors” in Dreamweaver Help (in Dreamweaver, 
select Help > Dreamweaver Help).
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