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Kindle and PDF

While this paper describes how to
convert an EPUB file for compatibility
with Amazon devices, the Kindle DX
does include native support for PDF
files. For the Kindle 1 and 2, however,
users must convert their PDF files in
order to view them. This conversion
can be accomplished either by using
Amazon's fee-based online
conversion service or following steps
2-4 of this paper to convert the PDF
file to the MOBI format, replacing all
references to EPUB with PDF. Since
PDF is designed for static page
layout—and not for reflow—results
will be better if you convert from an
EPUB file.

Technical Paper

eBooks:
From Adobe’ InDesign’
to the Kindle Store

As eReader devices like Amazon’s Kindle increase in popularity, Adobe InDesign users are
asking how to prepare their eBook documents for reading on the Kindle and selling on the
Amazon.com Kindle Store. This paper describes how best to accomplish this task. Generally,
InDesign users must first export an InDesign document into an EPUB file. Then they must
convert it using open source software into the MOBI format to view on a Kindle reading device
or to sell on the Amazon.com Kindle Store.

A multiplicity of formats

Although many eBook file formats exist, two are most prevalent: the EPUB format, created by
the International Digital Publishing Forum (to which Adobe belongs), and the AZW format,
created by Amazon. Because the Kindle doesn’t recognize EPUB files, users of a variety of
content creation tools that create EPUB files—including InDesign—must convert these files to a
format the Kindle can read. And since tools to convert to the native AZW format aren’t generally
available, users must convert EPUB files to an alternative format, MOBI, to view on the Kindle or
to sell on the Kindle Store.

This white paper provides a step-by-step guide to display your EPUB book on the Kindle:
1. Export InDesign document to EPUB.

2. Convert EPUB to alternative MOBI format.

3. Preview on a Kindle device (optional).
4

Upload to Amazon.com.

Requirements
To accomplish this conversion, you need the following:

» Adobe InDesign CS3 or CS4 software—While you can export to EPUB with InDesign CS3,
InDesign CS4 includes enhanced EPUB export features—like local formatting preservation
and floating anchored objects—that simplify the conversion process.

« Adobe Digital Editions software—Digital Editions is a free, lightweight eBook reading applica-
tion for PC and Mac. You can use it to read and organize your eBook collection, as well as
preview the EPUB files you export from InDesign.

o Calibre - A free, open-source eBook conversion tool, Calibre runs on Windows®, Mac OS, and
Linux®. Because the Kindle doesn’t include native support for the EPUB format, this paper
describes the use of Calibre to convert EPUB to the MOBI format (which is supported natively
in the Kindle).

To preview your converted documents you need a Kindle and its USB cord. If you don’t own a
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Image captions

For image captions to export

correctly to EPUB, you'll need to paste

them as a group inline with the text
and then create an anchored object.

Follow these tips to complete this

process:

1. Select the frames containing
the image and the caption text
and then choose Object >
Group.

2. Transfer the group to the
clipboard using Edit > Cut.

3. With the Text Selection tool,
select the location in the text
flow to which you want the
group to anchor.

4.  Paste the objectinline in the
text frame using Edit > Paste.

5. Using the Selection tool, select
the inline group.

6.  Choose Object > Anchored
Object to create and specify the
offset and behavior of the
anchored group.

Kindle, you can preview your converted documents online through Amazon’s Digital Text
Platform (http://dtp.amazon.com) Also, if you want to upload your eBooks to sell on

Amazon.com, you'll need an Amazon.com account.

Step 1: Export InDesign document to EPUB

One of the features in InDesign C$4 is the ability to export an InDesign document directly to
the EPUB format. As mentioned previously, this open document format is interoperable among a
variety of handheld eReader devices (like the Sony Reader), desktop reading applications for the
PC or Mac (like Adobe Digital Editions), and smartphone reading applications that display
eBooks on your mobile phone (like Stanza or Shortcovers).

To get started, create your document and add your text and images. While this paper doesn’t
review how to set up an InDesign document, the training resources at Adobe.com can point you
in the right direction should you need more information. See www.adobe.com/support/training/
products/indesign.html

Once you have your document set up, review the following tips to ensure your file is exported
properly to the EPUB format. Remember that these tips are general guidelines for exporting
production-quality EPUB files and are not necessarily specific to the MOBI conversion workflow
discussed later.

Layout

InDesign will export all your text frames as one single flow of text and in the order the frames
are threaded together. You’ll need to verify that you have threaded the frames in the correct
order. Remember also that the export feature doesn’t preserve individual object positioning on
the page; it exports all the elements into one continuous flow of text. To achieve perfect object
positioning, you'll most likely have to manually style the EPUB file after export (see link below
for more information on manual styling).

Styling

If your InDesign document contains local formatting (a manually bolded word without a
Character Style applied to it, for example), make sure you select the Local Formatting option
under Base for CSS Styles in the Digital Editions Export Options dialog. Local formatting export
is supported in the latest version of InDesign CS4 (v. 6.0.3). If youre using InDesign CS3, only
Character Styles, Paragraph Styles, and Object Styles are preserved during the export.

Chapters

If youre working with a long document with an expected final file size over 300KB that you
intend to display on a device, you’ll want to separate each chapter into a separate InDesign
document. To export all the chapters into the same EPUB document, create an InDesign book
(File > New > Book). From there, add the individual chapters using the Book panel (automati-
cally appears when working with a book), and then select Export Book for Digital Editions from
the Book panel commands.

Font embedding

In general, all fonts used in the document will be embedded in the resulting EPUB file. Note that
although EPUB supports font embedding, the MOBI format as displayed on the Kindle does not.
Consequently, you’ll see the standard Kindle font in your final document when displayed on a
Kindle device. In EPUB, OpenType fonts are supported during the export, as are most TrueType
fonts—but you should always test to ensure you see the results you expect.

Images

If the Formatted option is selected in the Images panel of the export dialog box, the exported
images will be reformatted to the size to which you have scaled them in your InDesign docu-
ment. This scaling reduces the file size of the final EPUB file. You will also want to anchor your
images to the relative area to which they belong in the text, or else they may all end up at the
beginning or the end of the document. Again, to achieve perfect image positioning, you may
need to manually style the EPUB file after export (see link below). For more information on
working with image captions, see the sidebar entitled Image captions.


http://dtp.amazon.com

For other tips on how to set up your document for correct export to the EPUB format, as well as
how to perform post-export manual editing, see “Producing ePub Documents from InDesign” at
http://blogs.adobe.com/digitaleditions/indesign-epub.html

After your document is correctly formatted, export it to the EPUB format by choosing File >
Export to Digital Editions.
R
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Image formats In the Digital Editions Export Options dialog box, select the EPUB options that fit your needs

best. You have the option to add publisher metadata, define the styling source, select image
output type (GIF or JPEG), and adjust the table of contents, among others.

If you're having trouble deciding
whether to output your images into
GIF or JPEG format, you can read
more about the differences between
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Previewing EPUB in Digital
Editions

Adobe Digital Editions is a free,
lightweight eBook reading
application for PC and Mac. In the
workflow outlined in this paper, it is
used to preview EPUB files for
accuracy before converting them to
the MOBI format. In addition, Digital mE

Editions allows you to: r—

If you've selected the View eBook after Exporting option on the previous screen, you’ll be able to
immediately see the results of your export, provided you have installed the free Adobe Digital
Editions eBook reader. To download Adobe Digital Editions, go to www.adobe.com/products/
digitaleditions/#download
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The busses leave a plume of exhaust on the avenida as they constantly pull up and away
from the white-painted curb. | am here in Santos with Adam the American and we are

« Read and easily navigate your EPUB/
PDF eBook files

- Organize your digital books and
view title metadata

« Insert annotations and bookmarks

« Play multimedia SWF files
embedded in eBooks

« Transfer eBooks to supported
devices

To download Digital Editions, go to

www.adobe.com/products/

digitaleditions/#download

noticeable because our heads stick above the pressing crowd at the bus stop. As the red-
striped bus pulls up, | crane my neck to see its placard at the top and realize that it is the
fourth bus | have seen for Sao Vicente in two minutes.

The bus curb in Santos is 35 minutes away from my beachside apartment in Praia Grande
and we are here because Adam the American had another Grand Idea. His last Grand Idea
involved giving digital cameras to Brazilians, which was relatively easy because he had his
mother package them up, neatly tie them with packaging string and let the clerk at the
Idaho post office handle the rest. Today’s Grand Idea involves a large, oversized swath of
sheet metal with which he (and |, by association) now maneuver in the crowd.

Itis already hot and sweaty and crowded on our now-arrived bus; nevertheless, the sheet
metal goes up through the back door. It is now more awkward than ever: the nudging, the
bumping, the asking politely of bus-riders to make way for the metal. At last Adam and his
metal are situated in the center aisle. In the back, though, the riders have bumped and
nudged each other in a domino effect. Crowd, heat, sweat and the bumping make one
man shove another, and another follows suit.

The back of the bus is in a melee and Adam the American stands oblivious in the aisle,
happy only for his metal. | open my window for some fresh air.
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Step 2: Convert EPUB to MOBI

With an EPUB file in hand, the next task is to convert it to the MOBI format. One of the simplest
ways to accomplish this is with the free, open-source Calibre conversion program. It runs on
Windows, Mac, or Linux and is available for download at http://calibre.kovidgoyal.net/download.

Calibre Setup
To get started with Calibre, download and install it. After installation, one of the first prompts
asks where you want to store the books that you’ll be converting. Select a location on your hard

drive and click Continue.

1 cabbre weicome wizard

Welcome to calibre

The one stop solution 1o all your e-book needs
Choose a kocation for your books. When you add
books to calibre, they will be copied here:

€ Crange )

1f you have an existing cabibre libeary, it will be
copied to the mew location. If a calibre library already

exists at the new location, calibre will switch to
using it

Next, in order to optimize the output of converted files, Calibre asks what type of eReader device
you have. Since this example assumes you’ll be mainly reading on a Kindle, go ahead and select
Amazon under Manufacturers and your Kindle version under Devices. If you plan to convert
books to a variety of formats, however, you might consider leaving the setting to Default.

1 cakbre weicome wizard

Welcome to calibre

The one stop solution 1o all your e-book needs

Choose your book reader, This wil set the
comversion options to produce books optimized for

Gona) (Comimos)
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Should you plan to use the Amazon fee-based wireless delivery service, fill in the e-mail
addresses requested on the following screen.

Ak calibre weicome wizard

Welcome to calibre

The one stop salution to all your e-book needs

calibre can automatically send books by emal to your Kindle. To do
that you have 10 setup email delivery below. The easiest way is to
setup a free gmail acount and click the Use gmail button below. You
will 4156 have 1o register your gmail addeess in your Amazon

account

Xindle email

Send email from

Mail Server

calibre can optionally use 3 serves to
send mail

Hostname Port. 25
Usemame
Passwoed

Test emad
Encryption: @ TLS

Go tack ) ("Continue )

calibre weicome ws

Welcome to calibre

The one stop solution 1o all your e-book needs.
Congratulations!

You have successfully setup calibre. Press the Done button to apply
your settings.

Demo videos

Videos demonstrating the various features of calibre are available

User Manual

AUser Manual is also available anline




Converting EPUB to MOBI in Calibre
Converting an EPUB book to the MOBI format in Calibre is a two step process: Add the EPUB
file to the Calibre library, and then initiate conversion of the EPUB file.

Adding EPUB files to the library

To add a single EPUB file to the library, click the “Add books” icon in the upper left corner of the
program. If you have multiple books to upload to the library at once, click the triangle immedi-
ately to the right of the icon, and select from the available bulk upload options.
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Add Empty book. (Book entry with no formats)
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You will be able to see the EPUB book in the list of available titles when the uploading process in
complete.
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Initiating the conversion

After you have your EPUB file in the Calibre library, you must convert it to the MOBI format. To
do this, select the EPUB file from the list of available titles and then click the Convert E-books
icon on the top menu bar.

After you've clicked this icon, the conversion dialog screen appears. Make sure that the output
format field in the upper right corner reads MOBI.

The panels on the left side allow you to adjust the conversion options. In the Metadata panel, you
can edit the book’s title, author, publisher, and cover image. The Look & Feel panel provides
fine-tuned adjustments on line spacing, font height, and non-roman characters. If you didn’t
select the Kindle as the output profile during the setup process, you can do so in the Page Setup
panel. The other panel options provide features for advanced users. When you are satisfied with
the selections you have chosen, initiate the conversion by clicking OK.
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eBooks and content protection You will know the conversion process is complete when the hourglass stops spinning in the lower
eBooks sold in online bookstores right-hand corner and a message displays on your screen. After converting a file, Calibre stores
generally have content protection

- i i the completed file in the library folder you selected during the first step of the setup process. Use
applied to them, using a solution

such as Adobe Content Server 4 a file browser to navigate to this folder, and verify the newly converted MOBI file is located in a
software. Content protection allows folder named after the author.

the bookseller to specify sharing and

printing rights. As a result, the Calibre Step 3: Preview on a Kindle (optional)

program cannot convert EPUB files To transfer your book to a Kindle device, first ensure that the Kindle is connected to your

with this Co,ntent protection. The computer via the USB cable. Then select the title from the available title list within the Calibre
program will, however, convert . . . w . .

unprotected books, like self-authored library. Click on the triangle next to the “Send to device” icon in the upper menu bar and then
publications or books in the public select “Send specific format to main memory”.
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A dialog box appears asking which format you would like to send to the connected Kindle device.
Since you just converted your EPUB file to the MOBI format, select MOBI.
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After the hourglass stops spinning and you receive a completion message, you should be able to
view your content on your Kindle device.

Alternatively, you may choose to transfer your converted MOBI files manually to your Kindle. To
do this, open the folder you selected as the Calibre library during the first step of the Calibre
setup process. Then connect your Kindle and navigate to its contents using a file browser. To
transfer your file, simply copy it from your hard drive to the Documents folder on your Kindle.

Step 4: Distribute your converted EPUB file on Amazon.com

Some authors may wish to distribute their converted EPUB documents using Amazon.com’s
self-publishing tool, the Digital Text Platform. To do this, you’ll need to log in with your existing
Amazon account (or create a new one) at http://dtp.amazon.com.
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After you have logged in, click the “Add new item” button at the upper left corner of the screen.
Then enter a few required details about your book, including title and the author’s name. You
also have the option to submit a product image and contribute a short description of your work.
After you've finished with this screen, remember to click “Save entries.”
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Next, Amazon will prompt you to upload your book. Browse to the location of your converted
MOBI file on your hard drive (in your Calibre library location, under a folder with the author’s
name) and then click “Upload”.
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After you've uploaded the file successfully, preview it to ensure that it will display as you expect.
Click the Preview button to display how your file will appear on the Kindle.
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After you are finished previewing, choose Menu > Close in the preview dialog box to return to
the previous page. Then click Enter Price. In this text field, enter the price for which you wish to
sell your eBook in the Kindle Store. Note that your price must be greater than US$0.99 and less
than US$200. When you are finished, click “Save entries”.
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Finally, when you are ready to distribute your eBook in the Kindle Store, click Publish at the
upper right side of the screen. Amazon may ask you on a subsequent screen for more informa-
tion on where to deposit your earnings.

Congratulations! You've successfully converted your eBook created in InDesign to a format that
can be read on a Kindle and sold in the Amazon.com Kindle Store.
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